summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild')
-rw-r--r--dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild b/dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild
deleted file mode 100644
index f3b9415e8536..000000000000
--- a/dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Zope testrunner script"
-HOMEPAGE="https://pypi.org/project/zope.testrunner/ https://github.com/zopefoundation/zope.testrunner"
-SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# TODO: extras?
-RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/zope-exceptions[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
- # some tests rely on .pyc files being present
- local -x PYTHONDONTWRITEBYTECODE=
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- # remove .pth files since dev-python/namespace-zope handles the ns
- find "${D}" -name '*.pth' -delete || die
-}