summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/loky/Manifest1
-rw-r--r--dev-python/loky/loky-3.0.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/loky/Manifest b/dev-python/loky/Manifest
index 45b7ee061405..5a3f027b3149 100644
--- a/dev-python/loky/Manifest
+++ b/dev-python/loky/Manifest
@@ -1 +1,2 @@
DIST loky-2.9.0.tar.gz 115019 BLAKE2B 2aa2042e32821b67db8b8de12d4b380d22af93d308bb35878271a4859325d6740a3bdab70b464a2c0d0af143903c8af3da81b4b804605cdae88779fefd7971a6 SHA512 d49354b834251f6f05a689ac44464aafa5a7a5b4a8ef84a308ec3bda138e810fc3dc31aa628307984dc69386a210f442d4c202b9499ae3e3864837b47a5b0cd9
+DIST loky-3.0.0.tar.gz 152463 BLAKE2B 99f0a1fc85e879626d12402dd4fee4b92345eab9520b1afaf95bbf869d2dc9e429f1f9810554e10d97f0ecbc4add28b1cbaee0477de05aa366faeb335eaef7c8 SHA512 ad171bfac031ab4d6749bde416031e905eb29adb97dab9c3348791c9df78b17e1e3eab8a354954d7c16fb2095ccc03d26cf2153fe53a546007a7a89c6046cb36
diff --git a/dev-python/loky/loky-3.0.0.ebuild b/dev-python/loky/loky-3.0.0.ebuild
new file mode 100644
index 000000000000..d1c230c8a53f
--- /dev/null
+++ b/dev-python/loky/loky-3.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Robust and reusable Executor for joblib"
+HOMEPAGE="https://github.com/joblib/loky"
+SRC_URI="
+ https://github.com/joblib/loky/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local args=(
+ # docker, seriously?
+ --deselect 'tests/test_loky_module.py::test_cpu_count_cfs_limit'
+ # hangs, and even pytest-timeout does not help
+ --deselect 'tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill'
+ # one test that uses a lot of memory, also broken on 32-bit
+ # platforms
+ --skip-high-memory
+ # breaks teardown
+ -p no:xvfb
+ )
+
+ epytest "${args[@]}"
+}