summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-2.16.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 5e69cb222122..7bca74ead0f7 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,2 +1,3 @@
DIST python-api-core-2.15.0.gh.tar.gz 193916 BLAKE2B 708bee6e62b4049d88bc88dfc03add6496ee1861954485e145ab01707284216aef224bd8646a3336417d8b114a8c196ce44e8da63e53c3dff3d616ff9bef25ad SHA512 1abbeb266e4bcb9cf8a2dc6ba795a5667b5e9a870fe8609335e929ac17410822e4324d88c7692f8c60534e9ee4b0933af0277cc44ccb2d805bcbaf8db1288bba
DIST python-api-core-2.16.0.gh.tar.gz 205401 BLAKE2B a36c1e76912038b5d239c02c586d79e96f6167b200dab7d97cee1f9dbf679a217a2a67ab2075c86bdeb81a42649229bcfe4940bba8d0ec707ea1d317c364125c SHA512 6ffe94ecb56bc9e67da644365726e3c03ad7a678f18019523e555e33d4226631162c7a749286273b735d4d0bf62af676bfac7c6d17ad1d074a1274c575c8d925
+DIST python-api-core-2.16.1.gh.tar.gz 205716 BLAKE2B 9fef4c669a40d2a8b8432e329aabb6c7d672bbfd912a01ba2629e080a95a82935f31389964b76050d814f85b4f66e6115f5c7339e193eec0012762cb9971968a SHA512 c9bba140e95f4a968297886937f96d86d7d2598699d7957ee4136be3741d52334f2525e1f9c2151ad4b9325456f36ace51ce7fd49079178d5d6049c45e2b0e7b
diff --git a/dev-python/google-api-core/google-api-core-2.16.1.ebuild b/dev-python/google-api-core/google-api-core-2.16.1.ebuild
new file mode 100644
index 000000000000..2c3f266b34e2
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.16.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/proto-plus[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+)
+
+python_test() {
+ rm -rf google || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio tests
+}