summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Nuitka/Manifest3
-rw-r--r--dev-python/Nuitka/Nuitka-1.4.5.ebuild54
-rw-r--r--dev-python/Nuitka/Nuitka-1.4.6.ebuild54
-rw-r--r--dev-python/Nuitka/Nuitka-1.4.7.ebuild54
4 files changed, 0 insertions, 165 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index fc1e9247d5ad..3d66bceea0d8 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,6 +1,3 @@
-DIST Nuitka-1.4.5.tar.gz 4131887 BLAKE2B b4eaea811a98f1ea5618a477841e2fd2ef41eb4c78635576fadae8a645456f9d47741d1b8c0c102e2774e1802d210785f31a10889d87441693215d84d06cabdd SHA512 fc628be6579f2b290d126fc9f16e16a2fcdd5457a28cb2caa1b2d4e23426933e502a3487485e54cf4e0f67d2d5bca97567d5502070e7ad46a03c513a1f6f9c9f
-DIST Nuitka-1.4.6.tar.gz 4131786 BLAKE2B a72d8b8925dfdd7ca6416912d725cd711c1f8cedabbdc4ea1764645d935529c2b1561c561c6fe8b8cd2babdadd0b6cd3c239ff7e844bd745cebc3b2d94cfbd63 SHA512 883806d787bd35c687bd0771a0f3182d1d157c4c0f403c5b60a03536631823fbdfbaf32c3c29f484aa7de3dacf01056183607109036f60c5602ab08072d8e40d
-DIST Nuitka-1.4.7.tar.gz 4132335 BLAKE2B 5c9e653c8ffa7ad9e757a20d4008e4e2a3083cfefcbce826f0904c0281a9be95dbfb78ad1aab2dd0819b9bf3a800a3b35ee422e38672655fdd900162f9c0d090 SHA512 fb219f5a53bc173365d23f4eae0814fa051c1312bc732ac2b717924dd2336bf140af0237834062223294c840f63b6b4766422f8fd189151ab73877eeb9c39ee6
DIST Nuitka-1.4.8.tar.gz 4132731 BLAKE2B 8e02acdb96596d5e74c486ae069ad4dba2ddff5e5b530d28f67551914eee8dc559fbe25d51454a18977d6e2877cdf9d3626cb5aad8942d0eb17b3e804ca0da21 SHA512 0d5646bf4b7f1de6f3015a59186ef2ff775f45326be6a83ede665e9a10003ed5c481b68016e863f196e5ab5cb2866ad1c6dacbe77edbfdecabab045ae1480b14
DIST Nuitka-1.5.1.tar.gz 4167830 BLAKE2B 751784fac712149ccd180d391333d8431c6492f58a33296fc5f41c00d4908d65760216afefb626ac00b30a29c93acb767abe83a907756cbaa807706c0d9d2ef7 SHA512 ff02439556c193b2e40c6a7edfc42c9178fed4f04c4f1fe01a223f8b2243bc5f66784af5666887c9f07aafcc9428ae785a7174c4c88c73d7b62e56cf2aafde5e
DIST Nuitka-1.5.tar.gz 4169208 BLAKE2B 9a0fed364ba69c01df309a23e08258c8149be81dcdfc26cbe2e5a08081eb98d1a6e2ce393dd372f30ee9f886c2d3f4f181387ab788f6393dd88799ea5298a8f8 SHA512 33c9cad89c021e4472194b769c54e84b965eab5f0c8715482ef33e3c94916b770dee1a9f400e402395fdc854322fd486c385d6e4f99fb328ac245e230db104e0
diff --git a/dev-python/Nuitka/Nuitka-1.4.5.ebuild b/dev-python/Nuitka/Nuitka-1.4.5.ebuild
deleted file mode 100644
index 6f373b0022b9..000000000000
--- a/dev-python/Nuitka/Nuitka-1.4.5.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_10 )
-
-inherit distutils-r1 flag-o-matic optfeature pypi
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="
- https://www.nuitka.net/
- https://github.com/Nuitka/Nuitka/
- https://pypi.org/project/Nuitka/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-util/scons[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- doman doc/nuitka3.1 doc/nuitka3-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}
diff --git a/dev-python/Nuitka/Nuitka-1.4.6.ebuild b/dev-python/Nuitka/Nuitka-1.4.6.ebuild
deleted file mode 100644
index 6f373b0022b9..000000000000
--- a/dev-python/Nuitka/Nuitka-1.4.6.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_10 )
-
-inherit distutils-r1 flag-o-matic optfeature pypi
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="
- https://www.nuitka.net/
- https://github.com/Nuitka/Nuitka/
- https://pypi.org/project/Nuitka/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-util/scons[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- doman doc/nuitka3.1 doc/nuitka3-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}
diff --git a/dev-python/Nuitka/Nuitka-1.4.7.ebuild b/dev-python/Nuitka/Nuitka-1.4.7.ebuild
deleted file mode 100644
index 6f373b0022b9..000000000000
--- a/dev-python/Nuitka/Nuitka-1.4.7.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_10 )
-
-inherit distutils-r1 flag-o-matic optfeature pypi
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="
- https://www.nuitka.net/
- https://github.com/Nuitka/Nuitka/
- https://pypi.org/project/Nuitka/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-util/scons[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- doman doc/nuitka3.1 doc/nuitka3-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}