summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyotp/Manifest1
-rw-r--r--dev-python/pyotp/pyotp-2.8.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyotp/Manifest b/dev-python/pyotp/Manifest
index e62ff8d553a0..967d46a1c6c7 100644
--- a/dev-python/pyotp/Manifest
+++ b/dev-python/pyotp/Manifest
@@ -1 +1,2 @@
DIST pyotp-2.7.0.tar.gz 16709 BLAKE2B 83b565afe4b718185274682540ad41591913a710d6683c0131dd7a47c100514e6dfea20d432aed39ab80ec232122329206841c3e024290160a86c74e3e8b3f65 SHA512 e2d67de9a7e4a711d4d0037c2a52c05be5b0ecb5fc85f942a1b9a14b261300dff0058be2fe2d2829d351cf665a0d238d3602c27184f56f7886a9049120c4e44f
+DIST pyotp-2.8.0.tar.gz 16873 BLAKE2B 55930ca0991a38e920e4dd31ff46534031976ccc4bd2151a762ce806251d1b4c7d3c120a7afa42b2aa33387cd445818b07b981f906733075535d6948dfde24e6 SHA512 f4e6c857833c7c994a64586bb495b48935752d0fa9d90edbdcce899ebce10fc0ac13ab03c439ea81f1c0fcfc4adafbf2c42ee8c4fa4afdd662c30d5be164c9b2
diff --git a/dev-python/pyotp/pyotp-2.8.0.ebuild b/dev-python/pyotp/pyotp-2.8.0.ebuild
new file mode 100644
index 000000000000..1309f77d2d96
--- /dev/null
+++ b/dev-python/pyotp/pyotp-2.8.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords"
+HOMEPAGE="
+ https://github.com/pyauth/pyotp/
+ https://pypi.org/project/pyotp/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests unittest