summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fitsio/Manifest1
-rw-r--r--dev-python/fitsio/files/fitsio-0.9.11-test-failures.patch38
-rw-r--r--dev-python/fitsio/fitsio-0.9.11.ebuild38
3 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/fitsio/Manifest b/dev-python/fitsio/Manifest
index 5d468a97cfeb..218062451e1a 100644
--- a/dev-python/fitsio/Manifest
+++ b/dev-python/fitsio/Manifest
@@ -1,2 +1 @@
-DIST fitsio-0.9.11.tar.gz 6020222 BLAKE2B a71a0a6a026999b06dce54beb48fab2f510951099788b51456a6e07057daa7c911d5a2841d5f15a397705459daf081ff91bff1014782c93cb1dd76faf0ef2e1d SHA512 751b9612fe051f128d8f5dea61e2d119409293051a130ee3e18836181637e8c8daea757a715012fd024678d00e234e8b6c0cc0c9229c2bd9a406db312e4607d7
DIST fitsio-1.1.7.gh.tar.gz 5052055 BLAKE2B be9c632dcdd08325c5abb2cb9ed9eee6476b27ef2e7197298b269156346ecb72afc9f1d1c2e3ade045f69cde3afac5a6bf3fe5ecbce67fdfc1e6ede529ab1b32 SHA512 d6e81de08c38346050fbaa3e2fb51a496e76133bb0b04f20d816b51b7b7bf21ba37a400c3a6a7f966959223545c736ca6245427457154a4b5976b5a997e9cfcc
diff --git a/dev-python/fitsio/files/fitsio-0.9.11-test-failures.patch b/dev-python/fitsio/files/fitsio-0.9.11-test-failures.patch
deleted file mode 100644
index 243913dc659e..000000000000
--- a/dev-python/fitsio/files/fitsio-0.9.11-test-failures.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From: Ole Streicher <olebole@debian.org>
-Date: Fri, 15 Jul 2016 08:46:15 +0200
-Subject: Mark failures that are known to fail with the original cfitsio
-
----
- fitsio/test.py | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/fitsio/test.py b/fitsio/test.py
-index bafde15..49a4b3b 100644
---- a/fitsio/test.py
-+++ b/fitsio/test.py
-@@ -545,7 +545,7 @@ class TestReadWrite(unittest.TestCase):
- try:
- with fitsio.FITS(fname,'rw',clobber=True) as fits:
- # note i8 not supported for compressed!
-- dtypes = ['u1','i1','u2','i2','u4','i4','f4','f8']
-+ dtypes = ['u1','i1', 'i2','u4','i4','f4','f8']
-
- for dtype in dtypes:
- data = numpy.arange(5*20,dtype=dtype).reshape(5,20)
-@@ -569,7 +569,7 @@ class TestReadWrite(unittest.TestCase):
- try:
- with fitsio.FITS(fname,'rw',clobber=True) as fits:
- # note i8 not supported for compressed!
-- dtypes = ['u1','i1','u2','i2','u4','i4','f4','f8']
-+ dtypes = ['u1','i1', 'i2','u4','i4','f4','f8']
-
- for dtype in dtypes:
- data = numpy.arange(5*20,dtype=dtype).reshape(5,20)
-@@ -1365,6 +1365,7 @@ class TestReadWrite(unittest.TestCase):
- if os.path.exists(fname):
- os.remove(fname)
-
-+ @unittest.skip("bzip2 is not supported with debian cfitsio package")
- def testBz2Read(self):
- '''
- Write a normal .fits file, run bzip2 on it, then read the bz2
diff --git a/dev-python/fitsio/fitsio-0.9.11.ebuild b/dev-python/fitsio/fitsio-0.9.11.ebuild
deleted file mode 100644
index c58f52da2827..000000000000
--- a/dev-python/fitsio/fitsio-0.9.11.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to read from and write to FITS files"
-HOMEPAGE="https://github.com/esheldon/fitsio"
-SRC_URI="https://github.com/esheldon/fitsio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
- sci-libs/cfitsio:0=
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-test-failures.patch )
-
-python_prepare_all() {
- sed -e '/self.use_system_fitsio/s/False/True/' \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- pushd "${TEST_DIR}"/ || die
- ${PYTHON} -c "import fitsio; exit(fitsio.test.test())" || die
- popd > /dev/null || die
-}