summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/comm/Manifest1
-rw-r--r--dev-python/comm/comm-0.1.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/comm/Manifest b/dev-python/comm/Manifest
index 8a2c5e105b09..fc32c96a0a88 100644
--- a/dev-python/comm/Manifest
+++ b/dev-python/comm/Manifest
@@ -1 +1,2 @@
DIST comm-0.1.2.gh.tar.gz 5382 BLAKE2B 698cd4823c86d5e589c6bfa1e99d534fc05c34d9c12ea417c0702f6e5b1397db9e334a78fcc445e59b55e4693e5460cb980357c7e299f01db8df3d0bdb2b6ddc SHA512 9cec9909676edc0c8abf41e6d90f83a6ebfa88266023b3b5fd9c1ffe3fe16ba324b68ab92e788bfa01d5304d5de6e6dc96c7238973f3b39f8c77fa5165df8379
+DIST comm-0.1.3.gh.tar.gz 7345 BLAKE2B 2cbe791d226316800a37886d8c68b05ac9d9860bc92e1d95f8b428038a090d9867abfa0860262a9daba3ccd4fd607743df4f8d7fb2c13bf63456d17aa5f69092 SHA512 05696e8b58245ecb02ef0b4e23e904bae8288a6dad6530a9e15587bb0922a8d57f32803a5a34eb8f79eb620f679bb77350842bc441c0ab665a7ca9f7196106c4
diff --git a/dev-python/comm/comm-0.1.3.ebuild b/dev-python/comm/comm-0.1.3.ebuild
new file mode 100644
index 000000000000..872e77ab10f3
--- /dev/null
+++ b/dev-python/comm/comm-0.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Python Comm implementation, for usage in ipykernel, xeus-python"
+HOMEPAGE="
+ https://github.com/ipython/comm/
+ https://pypi.org/project/comm/
+"
+# no tests in sdist, as of 0.1.3
+SRC_URI="
+ https://github.com/ipython/comm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest