summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyotp/Manifest1
-rw-r--r--dev-python/pyotp/pyotp-2.4.0.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/pyotp/Manifest b/dev-python/pyotp/Manifest
index 6ed3587391a5..969106969fc3 100644
--- a/dev-python/pyotp/Manifest
+++ b/dev-python/pyotp/Manifest
@@ -1 +1,2 @@
DIST pyotp-2.3.0.tar.gz 11672 BLAKE2B a3d8ca5296b5a8a7aa053b0a0556285c19f335cb1dfb4f892d40fe2d79cc52313af7b31c6ee4afc4eb8c1cd8cb8248442bd1a4868e2bb921a552332a0a283a44 SHA512 4a7a4206134e9a370f7f3c3a9b7e755b75a84e30a320084faf91af5607c4262a6aa76d7b8cefaf284e4cf01faea1df4ca92d871644a14ab56f04693b227485cf
+DIST pyotp-2.4.0.tar.gz 14789 BLAKE2B 3c228f0e8271aa0c6692000ae2b2a6407afe015a4a91851509d8878f325277c055e52e3f3385cf0139678406a1e09c0230743e6a09c2d64c291df6b770508d7c SHA512 cb6d49d0b6880c6d7c5ef6337d1f0085609e1b66c693b1a9cf6604334af6456cd67dd0278836211edb91a81b5340cab51499cd47b2013d291c9cc9d59e4f31a5
diff --git a/dev-python/pyotp/pyotp-2.4.0.ebuild b/dev-python/pyotp/pyotp-2.4.0.ebuild
new file mode 100644
index 000000000000..5334f2e81f8a
--- /dev/null
+++ b/dev-python/pyotp/pyotp-2.4.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords."
+HOMEPAGE="https://github.com/pyauth/pyotp https://pypi.org/project/pyotp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest