summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-iptables/Manifest1
-rw-r--r--dev-python/python-iptables/python-iptables-0.12.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-iptables/Manifest b/dev-python/python-iptables/Manifest
index 421530d645e2..55380564eafe 100644
--- a/dev-python/python-iptables/Manifest
+++ b/dev-python/python-iptables/Manifest
@@ -1 +1,2 @@
DIST python-iptables-0.11.0.tar.gz 73582 SHA256 55bdd0d8e3d0b4c27e4d61bf6f21ada1e19146c0adf65e5093e254a126abcce9 SHA512 5bbaeb09dc256738e3a168fa5941f39e50074eb1ac3ce18545a48c55eb06ef70fd974ad3153dc07ca67b1ef88a2a2c537a9f8d3ac85add990f6d15e9d37aa0a4 WHIRLPOOL 5ecc28a1f65389e63c962408f058ac0795a5ebd846320f4d9de4ad35e6bb7a8ee7dff4555af0c4c9c42d303b7b0f6de372c042d4219141446680ba45b8216ac4
+DIST python-iptables-0.12.0.tar.gz 40831 SHA256 9815fd5ba780fd14b5f8cf8a93e007c0e603019738813a806e37553cd72e4c33 SHA512 bf79288fac53542e523c8ed0e4e0711792cf524100e39f57f10d3581d1b958712875a765f690b3d5ec6e28af9de48d2f3dd0a787c7037ebfc6f8bf87b5e321b2 WHIRLPOOL 360c3dec7c1122ba53cf7f158ff463937a119fbc818ac879403ac943c0f0d04043c89559468274332e3050e4fd84a8d95f8a30b7a783aaa0c023420278c3422c
diff --git a/dev-python/python-iptables/python-iptables-0.12.0.ebuild b/dev-python/python-iptables/python-iptables-0.12.0.ebuild
new file mode 100644
index 000000000000..e294f95ec8fc
--- /dev/null
+++ b/dev-python/python-iptables/python-iptables-0.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for iptables"
+HOMEPAGE="https://github.com/ldx/python-iptables"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="net-firewall/iptables
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+# tests manipulate live iptables rules, so disable them by default
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}