summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-rtd-theme/Manifest1
-rw-r--r--dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.3.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/sphinx-rtd-theme/Manifest b/dev-python/sphinx-rtd-theme/Manifest
index 1890a72ba2dc..cc0c14a140ac 100644
--- a/dev-python/sphinx-rtd-theme/Manifest
+++ b/dev-python/sphinx-rtd-theme/Manifest
@@ -1 +1,2 @@
DIST sphinx_rtd_theme-1.2.2.tar.gz 2784122 BLAKE2B af738c99a2406daa0372171a34c78ee14e955fee589ba49811ea50fd2cdeeee431367fde4d6a34d9e4f532d1ed6d079b1cebf4bb390b573fb5fe9cfc8f02b838 SHA512 44272272ce14387c1252ec40325ff8f9b40da6e37206333a8e0831cdce76c45efe58cf28f08132188d2799527a40e4ead881e8577776a123921b1cd908dd17fe
+DIST sphinx_rtd_theme-1.3.0.tar.gz 2785069 BLAKE2B f9849a72941024de7537a3517e226e2cdc6b2067e043bcdf8bbb4cc29cdf8b0be67121f721d92d30ffccea367af62ff0ce71d5d00d8eafbb65a2ebf4ef8e5159 SHA512 41e8ebffd057c1c6efb41a05547067016e73047a1894340df92bb7e4232559de15b200f57a34cf1cf9f66e4af7019d66d12939a68d3b2b46460a1794a10fc32e
diff --git a/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.3.0.ebuild b/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.3.0.ebuild
new file mode 100644
index 000000000000..247f5a56e50d
--- /dev/null
+++ b/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ReadTheDocs.org theme for Sphinx"
+HOMEPAGE="
+ https://github.com/readthedocs/sphinx_rtd_theme/
+ https://pypi.org/project/sphinx-rtd-theme/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-jquery-4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/readthedocs-sphinx-ext[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove upper bounds
+ sed -i -e 's:,\?<[0-9.]*::' setup.cfg || die
+ distutils-r1_src_prepare
+
+ # CI=1 disables rebuilding webpack that requires npm use
+ # yes, that surely makes sense
+ export CI=1
+}