summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/ipyparallel-8.2.1.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 391be9dda1ed..140372be20b3 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -2,3 +2,4 @@ DIST ipyparallel-6.3.0.tar.gz 2380153 BLAKE2B b8312102e1d2b5fc963491ebe8530e2fd7
DIST ipyparallel-7.1.0.tar.gz 4029033 BLAKE2B badf4bdad0dca0898e62abee3e5a48b06460160bd1f2ae096bc05beb00dbd6dc2b52681aa699d69a76f5a51e4cd3f0bb107fa6b1d20109e76bc78da8f08b69f9 SHA512 9a629bd92176dbace1724efe0a5a698b2d684128567513f8809fd25e4901227d1c7fc7b02427fd3c14b3743b47956ff8387098a1cc8759d8987aa5e3d8ca60d5
DIST ipyparallel-8.1.0.tar.gz 9365732 BLAKE2B 847931de17f61b537a6350358a1fcc8e629b843e1216fcc0f60333f7baf42b0739f864bd1a02daefb839b90cfb4c65b6101de3271e89d529dd8493513b686ced SHA512 21e1d3d9e04c7567889e923ff0f1b140251518efd331dd2180a42142eedbb4c92eaeafce17bf2287e1d36ef4e5951f2f50021d9b9a96c266e4e94e1a3ac34347
DIST ipyparallel-8.2.0.tar.gz 9367069 BLAKE2B e4e881f774422ead72778d40d85e5732d7da8e8e66107c06d65557c6701c94bd5c2592cea2def8b2ad405db78fe70c87944e4b89eb9fe3a4bcf38464b008979a SHA512 f6e62eaa86fa63ef1417e850de3eaf5ba228a1ad1da99c66b64b371010b57ba805201f18c97485ded24899afe7b22edbec23ca0e21344e9c2c2eacfcd6fd8adf
+DIST ipyparallel-8.2.1.tar.gz 9367709 BLAKE2B 5be16c1060a31295e6b1908cfa3530d7ade6337de78ee057f595ab94ed5dc6c4c49b08f39ded0e8b6aa11ee7eda788f27b2f57bad851908f805d681e0b98efc3 SHA512 d06d1e272e27c0941f0fd6799cc78bbaf188ba1fb22f03016925ffbbf6b3e273eb8c372d7c0509b2f044ccfbfe3f35071547712e79a26a802e673340021921ac
diff --git a/dev-python/ipyparallel/ipyparallel-8.2.1.ebuild b/dev-python/ipyparallel/ipyparallel-8.2.1.ebuild
new file mode 100644
index 000000000000..14ba1f0ef224
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-8.2.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="https://ipyparallel.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-18[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython-4[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-4.4[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5.1[${PYTHON_USEDEP}]
+ "
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/ipython[test]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-tornado[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ "
+
+# TODO: package myst_parser
+# distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.1.0-test-timeouts.patch
+)
+
+src_configure() {
+ export IPP_DISABLE_JS=1
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # we don't run a mongo instance for tests
+ ipyparallel/tests/test_mongodb.py::TestMongoBackend
+ # TODO
+ ipyparallel/tests/test_util.py::test_disambiguate_ip
+ ipyparallel/tests/test_view.py::TestView::test_temp_flags
+ ipyparallel/tests/test_view.py::TestView::test_unicode_apply_arg
+ ipyparallel/tests/test_view.py::TestView::test_unicode_apply_result
+ ipyparallel/tests/test_view.py::TestView::test_unicode_execute
+ ipyparallel/tests/test_view.py::TestView::test_sync_imports_quiet
+ # Gets upset that a timeout _doesn't_ occur, presumably because
+ # we're cranking up too many test timeouts. Oh well.
+ # bug #823458#c3
+ ipyparallel/tests/test_asyncresult.py::AsyncResultTest::test_wait_for_send
+ # We could patch the timeout for these too but they're going to be inherently
+ # fragile anyway based on what they do.
+ ipyparallel/tests/test_client.py::TestClient::test_activate
+ ipyparallel/tests/test_client.py::TestClient::test_lazy_all_targets
+ ipyparallel/tests/test_client.py::TestClient::test_wait_for_engines
+ )
+ [[ ${EPYTHON} == python3.10 ]] && EPYTEST_DESELECT+=(
+ # failing due to irrelevant warnings
+ ipyparallel/tests/test_client.py::TestClient::test_local_ip_true_doesnt_trigger_warning
+ ipyparallel/tests/test_client.py::TestClient::test_warning_on_hostname_match
+ )
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ optfeature "Jupyter Notebook integration" dev-python/notebook
+}