summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-5.0.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index cc5048090470..939c004fc7ba 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1 +1,2 @@
DIST tempora-5.0.1.tar.gz 18456 BLAKE2B b21d60dc8fa5ff9701bbdf66cc9f657c9e4bc779a4a564ea788b201034f818a688c53bcd94f315ef4650b62cce1866fad4a196e2ab724e89670bbc36e9ea15ac SHA512 941b1a231bfae6cf2321325ada785806578643dc9ae215116393623f780de7a409f918c215aae353013bd89c6866ab870ac61470af09f281af0953ce6e20ea3b
+DIST tempora-5.0.2.tar.gz 19530 BLAKE2B 9c07fc294ef77d9a12276578ffdde39ef58508075deb98c0a89d6179bc7c9cbb7633d20077801a1d99d5c016c72206f508e5d7cd6af5667704b025ffccabe552 SHA512 d0fe086b92e21622444b941c583e3432420b1826e60aa4b90bab31907a98b4989dd21ca99b5554e965f87e23c9d65d9bce8e434d801985f99f187b7dad2a715a
diff --git a/dev-python/tempora/tempora-5.0.2.ebuild b/dev-python/tempora/tempora-5.0.2.ebuild
new file mode 100644
index 000000000000..e32d2ca05b4c
--- /dev/null
+++ b/dev-python/tempora/tempora-5.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest