summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-2.17.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 15a1945e7528..8c3e4e50a9e4 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -3,3 +3,4 @@ DIST python-api-core-2.16.0.gh.tar.gz 205401 BLAKE2B a36c1e76912038b5d239c02c586
DIST python-api-core-2.16.1.gh.tar.gz 205716 BLAKE2B 9fef4c669a40d2a8b8432e329aabb6c7d672bbfd912a01ba2629e080a95a82935f31389964b76050d814f85b4f66e6115f5c7339e193eec0012762cb9971968a SHA512 c9bba140e95f4a968297886937f96d86d7d2598699d7957ee4136be3741d52334f2525e1f9c2151ad4b9325456f36ace51ce7fd49079178d5d6049c45e2b0e7b
DIST python-api-core-2.16.2.gh.tar.gz 205804 BLAKE2B a0bc9668d0fb9958ecce78c23cd432399ff8d3a63536275e4b39d76f518da39ad2b3761e10e62475b0ad07216f353ea23d2c172ee524920be4a87530b3331489 SHA512 c7014c06d8038ee078dede46dcc2ffffffad9934c5fa55ec9445a9d73ac1d5e2eb8db4a4240d072ea2352727f3621de29769b1efe8cd72682f749e338f8db0c3
DIST python-api-core-2.17.0.gh.tar.gz 208432 BLAKE2B e0990ffe1c1fa9ca928d4a5d5d10613d05fab34505416dcf6bc40b56873d097a606207a9cbad9485873d6e98bb006d42be6efacd639adee3c5878aa9fce79a29 SHA512 2e0c492a0c085c04682216c90e787a1f2a0b0deb746a8724283f2f4d0e32f134349b170514aa8077ff9061b347bb2734bd4d76dec90581e0cf7c59de454b777a
+DIST python-api-core-2.17.1.gh.tar.gz 209222 BLAKE2B 8a851388268953897d6bef6a072adac4d539459af7f64db609ccb9ce8b91f617d3bfd8a8dc3fa6433107e70ca9f8ef441fe8f717fc4905a57e621871bbc8cac1 SHA512 7381723c64b5e145f88b7e01b510c64e222088df3a9c4ce6ddbd0c491d44514c12dc61bdd67d78391c0d6c247e9e1a0f092b7e04a9222fc96b6360e95b48f157
diff --git a/dev-python/google-api-core/google-api-core-2.17.1.ebuild b/dev-python/google-api-core/google-api-core-2.17.1.ebuild
new file mode 100644
index 000000000000..2c3f266b34e2
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.17.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/proto-plus[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+)
+
+python_test() {
+ rm -rf google || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio tests
+}