summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypdf/Manifest2
-rw-r--r--dev-python/pypdf/pypdf-3.17.4.ebuild59
-rw-r--r--dev-python/pypdf/pypdf-4.0.0.ebuild62
3 files changed, 0 insertions, 123 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index 691e95ae815b..0777a3d24696 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,4 +1,2 @@
-DIST pypdf-3.17.4.gh.tar.gz 7976829 BLAKE2B c2b7aef937186aecf525729f336ad6d00a8bf40850be17cb450daba5d0100acc0b0c3f51ef242e3cf7ef710d5c40c9f334db94a372b6d6eb4f2270dc00dde156 SHA512 f687a2032f085dac9b920f881f2df9f96e4da2a8dcdd5f971d3601ab05ae4f9b5528d0155adcb5ef01c6d8ffdc4f3d79077706915851bad7868bf761d28c513a
-DIST pypdf-4.0.0.gh.tar.gz 7992828 BLAKE2B 97ab3783ab91ebc638b625fe39c3008516de82f1ac384a45ef27a06bb0b91a86a5fdc24efbb92644a4355743b24e86f68822858eef2df39a3b6415795276c7c4 SHA512 488adffc330bb372df245d2dfdaee357bcd4303cc33d7ee31fd7abc393ce366c78715ca4a6516795ada6b5517ca32fec5f24cdad15e0d2c109fa90ebd2f9b05c
DIST pypdf-4.0.1.gh.tar.gz 7992979 BLAKE2B a072b50d177a89133bd5c7a74cae1d4f4ed5d6bcb1d78c68573c98f792a28a8ded26b5a82743a70ec2cd41651db8a19580cc48b0376c0dfe2f422826311914c3 SHA512 e9170b75ab00ce86580194bfa64ff3a31eb6fca62adc006478fcee3a78a99df269c75857672838c2b752b78b19174883cecb2eea5586878f81eb75474fabee6d
DIST pypdf-sample-files-964fb47b0fbfa89864680582640ae4eedf143890.gh.tar.gz 11668924 BLAKE2B 0c7d8e7cfb2f9d06d7633d57b691ba473d33cfcb58d2f1f83661cef9d755340d05db8767771a385d0ba88aa904f84b8bc7eafdb5d4f614b7a21a2d138572316f SHA512 28070b575273b6fee3173e797ed5bac618f8e8aca16d0122dcf3b4b16cedbcad69b84a9bc4be65037695597bcc1fa7898cdf766c37915c49f880a0c6ca057e68
diff --git a/dev-python/pypdf/pypdf-3.17.4.ebuild b/dev-python/pypdf/pypdf-3.17.4.ebuild
deleted file mode 100644
index 202f6fc746fa..000000000000
--- a/dev-python/pypdf/pypdf-3.17.4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-SAMPLE_COMMIT=964fb47b0fbfa89864680582640ae4eedf143890
-DESCRIPTION="Python library to work with PDF files"
-HOMEPAGE="
- https://pypi.org/project/pypdf/
- https://github.com/py-pdf/pypdf/
-"
-SRC_URI="
- https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- test? (
- https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
- -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
- )
-"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
-
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # rely on -Werror
- tests/test_utils.py::test_deprecate_no_replacement
- tests/test_workflows.py::test_orientations
- tests/test_writer.py::test_remove_image_per_type
- # TODO: requires fpdf
- tests/test_page.py::test_compression
- tests/test_writer.py::test_merging_many_temporary_files
-)
-
-src_unpack() {
- default
- if use test; then
- mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
- fi
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -o addopts= -m "not enable_socket"
-}
diff --git a/dev-python/pypdf/pypdf-4.0.0.ebuild b/dev-python/pypdf/pypdf-4.0.0.ebuild
deleted file mode 100644
index 6626238ceb3f..000000000000
--- a/dev-python/pypdf/pypdf-4.0.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-SAMPLE_COMMIT=964fb47b0fbfa89864680582640ae4eedf143890
-DESCRIPTION="Python library to work with PDF files"
-HOMEPAGE="
- https://pypi.org/project/pypdf/
- https://github.com/py-pdf/pypdf/
-"
-SRC_URI="
- https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- test? (
- https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
- -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
- )
-"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- tests/test_reader.py::test_decode_permissions
- tests/test_workflows.py::test_text_extraction_layout_mode
- # rely on -Werror
- tests/test_utils.py::test_deprecate_no_replacement
- tests/test_workflows.py::test_orientations
- tests/test_writer.py::test_remove_image_per_type
- # TODO: requires fpdf
- tests/test_page.py::test_compression
- tests/test_writer.py::test_merging_many_temporary_files
-)
-
-src_unpack() {
- default
- if use test; then
- mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
- fi
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -o addopts= -m "not enable_socket"
-}