summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sqlalchemy-migrate/Manifest1
-rw-r--r--dev-python/sqlalchemy-migrate/files/sqlalchemy-migrate-0.11-disable-sphinx-exts.patch13
-rw-r--r--dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.12.0.ebuild42
3 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/sqlalchemy-migrate/Manifest b/dev-python/sqlalchemy-migrate/Manifest
index 7e5ec8c2b155..f97e9647ceb0 100644
--- a/dev-python/sqlalchemy-migrate/Manifest
+++ b/dev-python/sqlalchemy-migrate/Manifest
@@ -1,2 +1 @@
-DIST sqlalchemy-migrate-0.12.0.tar.gz 128499 BLAKE2B 352b34f0c9490019748183dfd9c4b7e0064fece007de9ea46da88bcb7187b55ae3b502b45c919aac0d89586e4b9a19955be2df3ef81dc8b8328a0e9da7177e46 SHA512 bbab28a67afadfeb33a0a3c303c7e623de051923fef7c30b1896cb2f34fe325036c3730d93ad5f88ffb35aff25de22e1c770dff68dedd6acfbc4027e127857fb
DIST sqlalchemy-migrate-0.13.0.tar.gz 131424 BLAKE2B 925ee05144360c469d714342005c8b79dc0f1ef7c07ec641c00ec39e4aa18046b3afa7524f4e5afeb292cf78b2b85bac714f44102e0daf799ce09f0af40f3047 SHA512 1ca826a5d80c1373ffc4b2366dfb6d5dd24204964462873451c97d8ff4d75fc6c63f663c4769b7f6cc00002f6a98d425f41d759e5c010b4b81a8b74ffbb102b6
diff --git a/dev-python/sqlalchemy-migrate/files/sqlalchemy-migrate-0.11-disable-sphinx-exts.patch b/dev-python/sqlalchemy-migrate/files/sqlalchemy-migrate-0.11-disable-sphinx-exts.patch
deleted file mode 100644
index afb8ff6dc461..000000000000
--- a/dev-python/sqlalchemy-migrate/files/sqlalchemy-migrate-0.11-disable-sphinx-exts.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-intersphinx: prevent resource downloads at build time\
-issuetracker: broken. see bug #527188
---- a/doc/source/conf.py
-+++ b/doc/source/conf.py
-@@ -28,7 +28,7 @@ sys.path.append(os.path.dirname(os.path.abspath('.')))
-
- # Add any Sphinx extension module names here, as strings. They can be extensions
- # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
--extensions = ['sphinx.ext.autodoc', 'sphinx.ext.intersphinx', 'sphinxcontrib.issuetracker']
-+extensions = ['sphinx.ext.autodoc']
-
- # link to sqlalchemy docs
- intersphinx_mapping = {
diff --git a/dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.12.0.ebuild b/dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.12.0.ebuild
deleted file mode 100644
index 4ba81e9d0dba..000000000000
--- a/dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.12.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="SQLAlchemy Schema Migration Tools"
-HOMEPAGE="https://pypi.org/project/sqlalchemy-migrate/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-python/sqlalchemy-0.9.6[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
- dev-python/sqlparse[${PYTHON_USEDEP}]
- >=dev-python/tempita-0.4[${PYTHON_USEDEP}]"
-# Testsuite requires a missing dep and errors with poor report output
-
-PATCHES=( "${FILESDIR}/${PN}-0.11-disable-sphinx-exts.patch" )
-
-python_compile_all() {
- if use doc; then
- einfo ""; einfo "The build seeks to import modules from an installed state of the package"
- einfo "simply ignore all warnings / errors of failure to import module migrate.<module>"; einfo ""
- emake -C doc/source html
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/source/_build/html/. )
- distutils-r1_python_install_all
-}