summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/vcrpy/Manifest2
-rw-r--r--dev-python/vcrpy/vcrpy-4.2.1-r1.ebuild59
-rw-r--r--dev-python/vcrpy/vcrpy-4.2.1.ebuild58
-rw-r--r--dev-python/vcrpy/vcrpy-4.3.0.ebuild60
4 files changed, 0 insertions, 179 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 81e7aaabc26b..7cb8130e51b3 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,5 +1,3 @@
-DIST vcrpy-4.2.1.gh.tar.gz 331180 BLAKE2B 345e4c148963e2109d02be4e96986083236bd29fa8049c7cc54483f12d0506cde5c116b6f2fe80e099599b22a73e2f6240f7bb91e4a7d8af7f4e8e741097160d SHA512 59231e5164cda3099b18d099f0ef97e062e6401e52e5dfc4022aa89ca02881e9e6e3c782f12c288f5281b3b3bf175dc33a267bc6d2b40791582a1221f5d7aaab
-DIST vcrpy-4.3.0.gh.tar.gz 331605 BLAKE2B 92f995d21d986c20445ca6200778e9097fce7d4e44e8812018d5bf04b5f8f93bacf922f5332af59d3e147d6f43d8e3ab4afbbd65ba1314b760479029a64d01bd SHA512 772eb9cf23336ff961fc381a878a4e3e7a1cd81bbd6282f5a945536fd1c6b6d866fecfcfa582c9305de045e953186fea857a18d9f66012be36833d3a489b52ec
DIST vcrpy-4.3.1.gh.tar.gz 332412 BLAKE2B c2de3c9c3398bfe132b8a103566c6b1f48532d909d9c015b02349ef1283757ac75a31730f35b66ba211aaa1c015ffdf026da388a0a272deac2736e9e57d8ef32 SHA512 3ba3354ec0f1b8985890e70c6adff3416350adfa9dfec1db99051c2e1271f321bddf6e2dcd736a77ef953b71e4b5b0555cf05273443231e87a180f52b2372c9a
DIST vcrpy-4.4.0.gh.tar.gz 335402 BLAKE2B 1b32105ec7f319ea32318ce7193a433afa0e5e3da36531aa1d9a414b669150feb34490ea575f728569b622e740c42f73e22590ffda9aa9ed33a0bee2e11ac8ec SHA512 0b322cd688a9896cfd74ffd32de9560de9109a103989e04204868382b060621910ae0f0df456e1ed53576ecd8bb1e1f0c4c5d1500f4f6d291772f505ba36deba
DIST vcrpy-5.0.0.gh.tar.gz 336090 BLAKE2B f8460956456c332be24736153326651a319f3c25f8a38aab27f5a39ff9e312d0643ce702951cd906e735cbaa7c469cc948ce7599a37c767ef379fa10ff5ff69e SHA512 dcf1564b9e8640fe4998d13f4a74a892c6ac152bade6db2b040577e7a3b5e83b87f02a3ea93d58d3102ec6bbd6e452f5bd85c03273fb67fd6800caf87b5f3c6b
diff --git a/dev-python/vcrpy/vcrpy-4.2.1-r1.ebuild b/dev-python/vcrpy/vcrpy-4.2.1-r1.ebuild
deleted file mode 100644
index d7df7e9d76bc..000000000000
--- a/dev-python/vcrpy/vcrpy-4.2.1-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
-HOMEPAGE="
- https://github.com/kevin1024/vcrpy/
- https://pypi.org/project/vcrpy/
-"
-SRC_URI="
- https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-# <urllib3-2 for https://github.com/kevin1024/vcrpy/issues/688.
-RDEPEND="
- >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- <dev-python/urllib3-2[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
- dev-python/yarl[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # these tests require Internet
- tests/integration/test_aiohttp.py
- tests/integration/test_boto.py
- tests/integration/test_httplib2.py::test_effective_url
- tests/integration/test_httpx.py
- tests/integration/test_urllib2.py::test_effective_url
- tests/integration/test_urllib3.py::test_redirects
- tests/integration/test_wild.py::test_amazon_doctype
- tests/integration/test_wild.py::test_flickr_should_respond_with_200
- tests/unit/test_stubs.py::TestVCRConnection::testing_connect
- )
-
- local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
- epytest
-}
diff --git a/dev-python/vcrpy/vcrpy-4.2.1.ebuild b/dev-python/vcrpy/vcrpy-4.2.1.ebuild
deleted file mode 100644
index 98302c800df6..000000000000
--- a/dev-python/vcrpy/vcrpy-4.2.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
-HOMEPAGE="
- https://github.com/kevin1024/vcrpy/
- https://pypi.org/project/vcrpy/
-"
-SRC_URI="
- https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
- dev-python/yarl[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # these tests require Internet
- tests/integration/test_aiohttp.py
- tests/integration/test_boto.py
- tests/integration/test_httplib2.py::test_effective_url
- tests/integration/test_httpx.py
- tests/integration/test_urllib2.py::test_effective_url
- tests/integration/test_urllib3.py::test_redirects
- tests/integration/test_wild.py::test_amazon_doctype
- tests/integration/test_wild.py::test_flickr_should_respond_with_200
- tests/unit/test_stubs.py::TestVCRConnection::testing_connect
- )
-
- local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
- epytest
-}
diff --git a/dev-python/vcrpy/vcrpy-4.3.0.ebuild b/dev-python/vcrpy/vcrpy-4.3.0.ebuild
deleted file mode 100644
index c79ba759c2f7..000000000000
--- a/dev-python/vcrpy/vcrpy-4.3.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
-HOMEPAGE="
- https://github.com/kevin1024/vcrpy/
- https://pypi.org/project/vcrpy/
-"
-SRC_URI="
- https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-# <urllib3-2 for https://github.com/kevin1024/vcrpy/issues/688.
-RDEPEND="
- >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- <dev-python/urllib3-2[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
- dev-python/yarl[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # these tests require Internet
- tests/integration/test_aiohttp.py
- tests/integration/test_boto.py
- tests/integration/test_httplib2.py::test_effective_url
- tests/integration/test_httpx.py
- tests/integration/test_record_mode.py::test_new_episodes_record_mode_two_times
- tests/integration/test_urllib2.py
- tests/integration/test_urllib3.py::test_redirects
- tests/integration/test_wild.py::test_amazon_doctype
- tests/integration/test_wild.py::test_flickr_should_respond_with_200
- tests/unit/test_stubs.py::TestVCRConnection::testing_connect
- )
-
- local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
- epytest
-}