summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/natsort/Manifest1
-rw-r--r--dev-python/natsort/natsort-8.3.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/natsort/Manifest b/dev-python/natsort/Manifest
index f61cae68c042..d8602650e030 100644
--- a/dev-python/natsort/Manifest
+++ b/dev-python/natsort/Manifest
@@ -1 +1,2 @@
DIST natsort-8.2.0.tar.gz 145643 BLAKE2B d101ae2fa1cb009892e9712ece87d3825f3fca7970475e46176e5acbc29481ac79d491f1bae0721d85d3e67ecf39e5f54e2a984f0398356f32a5f0ec18a3e98d SHA512 d7e35c48ee36e69812c26b2cd333c57f1ec70c54017c4f51ed06dbb7619afc11cd1d589035faee700e1adf1e6b759b43ee497685fc88518be62c41957e15884e
+DIST natsort-8.3.0.tar.gz 123448 BLAKE2B 7fd480c8bfaceaca7431716e7721acac89d4a5c87a951ecf2754d80062437776eee823d7b94c58e2b9bc6864d9c0f595ee8667c538609c296694a548c126ab58 SHA512 63a65a99c9475e8ae96d722ae4c093cc73034c0dfdd254b24ae02904dd81cc8be36038c8a3fc514080f436d4124847f0f331d06a87c435f0b7b7d1d72313ae0d
diff --git a/dev-python/natsort/natsort-8.3.0.ebuild b/dev-python/natsort/natsort-8.3.0.ebuild
new file mode 100644
index 000000000000..5b947e1cf1a3
--- /dev/null
+++ b/dev-python/natsort/natsort-8.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="
+ https://github.com/SethMMorton/natsort/
+ https://pypi.org/project/natsort/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "sorting results that match most file browsers" "dev-python/pyicu"
+}