summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/smmap/Manifest1
-rw-r--r--dev-python/smmap/smmap-5.0.1.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/smmap/Manifest b/dev-python/smmap/Manifest
index ac798d0870cf..e360188506a1 100644
--- a/dev-python/smmap/Manifest
+++ b/dev-python/smmap/Manifest
@@ -1,2 +1,3 @@
DIST smmap-5.0.0.tar.gz 22437 BLAKE2B 2ff55ff412b10fe6c431df5f1589deb9f6f1c3277ee1ac651513e302d31b4f7ff986bfc548c5fefd66775f0eb7aef11dd8f2821f0e50a2e76d9bfcfaa9c047bd SHA512 03ae478bc83d02416f57bb3f6afc9c80bcb2d4249f3169390ac139b88be94258463dee7744fdf0fd54a7cfe109795a110c43f2b81ffd8546601de274667d353d
+DIST smmap-5.0.1.tar.gz 22291 BLAKE2B a57c0d5814697ec75ee2a6a227d0d1e3ee99536ac942aa29c4cb0ff5af6648ebb8af210c0c1a35812f63317ad3651573186d750585f85c0b112b9f5bd8916e3b SHA512 e40e802a8810a4eb6ec093739e6296bf600220315dffed191f780bd355c83ae8ef0b2c60a9032aa4813bcfdc22aa4241b73213eac9112b8e2209eacdd60baa85
DIST smmap-6.0.0.tar.gz 22266 BLAKE2B a2858d9c80b53f300386006e5e8289eb2d7081338065d87be66d55b78ade0cdb3c7bbace084b80d44fa9307ad04df7fa70206d3c5d104eb748a5f68287d2629a SHA512 ef5c79bcb3228cf50ce5c55762948a167b1cd1e4a0d47cc608702d04be7b0c26b4ff83a788cb8ebfcfb530eefad924149850ad651b23d7de83f5fdaa426fe2ec
diff --git a/dev-python/smmap/smmap-5.0.1.ebuild b/dev-python/smmap/smmap-5.0.1.ebuild
new file mode 100644
index 000000000000..b2ac0818d228
--- /dev/null
+++ b/dev-python/smmap/smmap-5.0.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python implementation of a sliding window memory map manager"
+HOMEPAGE="
+ https://pypi.org/project/smmap/
+ https://github.com/gitpython-developers/smmap/"
+
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+distutils_enable_tests unittest