summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tenacity/Manifest1
-rw-r--r--dev-python/tenacity/tenacity-8.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
index f52d8d2b963e..615a34b4522f 100644
--- a/dev-python/tenacity/Manifest
+++ b/dev-python/tenacity/Manifest
@@ -1 +1,2 @@
DIST tenacity-7.0.0.tar.gz 33874 BLAKE2B 485b35058e246ac7c68a2d92a4bd30ae182d382d4258854afb1e61d0b31cd1674bfd92599b83425f4e9a92ca4c38e4a91b72a17d0de6f918474ebe59e6bd2d66 SHA512 a627112df19b9f6d1c53294daad7fe1b0aeaed15e6ec07054228575fbc76ca5c22f560ddd6fc176c5c22141669423547ba17f1e33c7d0e7e92d0188acad065c4
+DIST tenacity-8.0.0.tar.gz 35483 BLAKE2B bde48a9682d1ce661ec6a35387c8a3931e60f61ac605b95637ce88176a5346eed54047623d0ee116e5c6d279f265d9cee0fd69e2b805c50cd7e06390d6952813 SHA512 f9c8b74d53dc4973e833a2d2625d15b7f40b813b1cfe389511c1083e738d62b0793dbfab73ed13a9e88cc65a17d2c6d8b0a571f13732a26f4c957e16dd9bbefc
diff --git a/dev-python/tenacity/tenacity-8.0.0.ebuild b/dev-python/tenacity/tenacity-8.0.0.ebuild
new file mode 100644
index 000000000000..4d837bd1e2de
--- /dev/null
+++ b/dev-python/tenacity/tenacity-8.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="https://github.com/jd/tenacity"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # TODO: package typeguard
+ tests/test_tenacity.py::TestRetryTyping::test_retry_type_annotations
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}