summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mccabe/Manifest1
-rw-r--r--dev-python/mccabe/mccabe-0.2.1.ebuild22
-rw-r--r--dev-python/mccabe/mccabe-0.6.1.ebuild31
3 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/mccabe/Manifest b/dev-python/mccabe/Manifest
index 4c9a424dc1b2..112a1e13f737 100644
--- a/dev-python/mccabe/Manifest
+++ b/dev-python/mccabe/Manifest
@@ -1,2 +1 @@
-DIST mccabe-0.2.1.tar.gz 5031 BLAKE2B 6f52106337ed534933de0c98fc103cfe209bddb30623a3b710681f4f0615a964c4d0472d4dc56f1ea4e60dda695eee540f9f9b441111808684f09fc8207b69d0 SHA512 7155e52063e786c140c541f1410d0c319387b4b5f24ec3c60ba3d5a963a92d0ee545254559941ac0dbe961f46750c0e61271fbe82653c6b1465c0a13b31ec325
DIST mccabe-0.6.1.tar.gz 8612 BLAKE2B 6828dfd852cf9b47de10bd889dd4c32dc1ee95910fbd27e0921cd7d9975a0831b1c2763eda5b2d77d7e4b44b5a9d0e89f0818cab71de655954cc87cacfe8d382 SHA512 d8fc251a29790887c14c5932c5172b4cd578cd37ccf14cb96e80f0b97f27023427ea032d14e1e2a99d72627b055eb285f60db69e679ecd79d90a34b0255703d8
diff --git a/dev-python/mccabe/mccabe-0.2.1.ebuild b/dev-python/mccabe/mccabe-0.2.1.ebuild
deleted file mode 100644
index 88bf7408106b..000000000000
--- a/dev-python/mccabe/mccabe-0.2.1.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A plugin for flake8"
-HOMEPAGE="https://github.com/flintwork/mccabe"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sparc x86"
-IUSE=""
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/pep8-1.4.3[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/mccabe/mccabe-0.6.1.ebuild b/dev-python/mccabe/mccabe-0.6.1.ebuild
deleted file mode 100644
index 6f46dd71dcec..000000000000
--- a/dev-python/mccabe/mccabe-0.6.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="flake8 plugin: McCabe complexity checker"
-HOMEPAGE="https://github.com/PyCQA/mccabe"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -i -e '/pytest-runner/d' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}