summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/natsort/Manifest1
-rw-r--r--dev-python/natsort/natsort-7.2.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/natsort/Manifest b/dev-python/natsort/Manifest
index 136ffe137d71..a6621daf5178 100644
--- a/dev-python/natsort/Manifest
+++ b/dev-python/natsort/Manifest
@@ -1 +1,2 @@
DIST natsort-7.1.1.tar.gz 142749 BLAKE2B dffd5b7b18ac49653d4d65ae1335c85d441748903aa983df092778476988cf0ca59c08526ee0da1761fce1afe4849d4c9a9e2f3e0c5400ebca2478781d0986dc SHA512 1903c933c6203ef0cd194ea444d79276b79ec385728a92b6e73d1698abc8e1351e96ed8ea4ae5f9f413ef6daecfd269a4d0de74c45eedff682fe929d8f977f30
+DIST natsort-7.2.0.tar.gz 144338 BLAKE2B cba2a547813b56c3f42a6d9526be59ebda0e12f964ce72e166dec825ceab923b06f7be768e4071f9380e7b8c2a2d24a5b9af0ad0752e48655046bca44fd03ab9 SHA512 9490d4f3f304834a82f91fc7f215a9212e5e4a2c78e2d0943d886cff2f50c581171bd27edc8ceec23981ebaf8d13d3be2bf1954439dd76aef9a2cc9983b1968a
diff --git a/dev-python/natsort/natsort-7.2.0.ebuild b/dev-python/natsort/natsort-7.2.0.ebuild
new file mode 100644
index 000000000000..59e2abfb948a
--- /dev/null
+++ b/dev-python/natsort/natsort-7.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="https://pypi.org/project/natsort/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest