summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mako/Manifest1
-rw-r--r--dev-python/mako/files/mako-1.1.1-pypy3-test.patch31
-rw-r--r--dev-python/mako/mako-1.1.6.ebuild33
3 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/mako/Manifest b/dev-python/mako/Manifest
index e1f51ad90193..ecd482abd751 100644
--- a/dev-python/mako/Manifest
+++ b/dev-python/mako/Manifest
@@ -1,2 +1 @@
-DIST Mako-1.1.6.tar.gz 495132 BLAKE2B bbdf0db9303f5d369b5c6c6644ee44d767630f51305ae259c44c65a3fba959a07d9833fdc69fc8168f7424cc0c3a05e991daae239bef8392c01396c1295967c7 SHA512 e87d883d7a549a902bb2e16d20306ccd3dd7b3bf855dfdaff20477dd182a782a5cecbdc447e4b1607f190a7b0febcca001333137f7cac6ffa674824c2a2fd1bb
DIST Mako-1.2.0.tar.gz 488603 BLAKE2B 30ef597e2dd500d52d02118e0ec8a40cfeeff00604eb9fec887df4aff794aed7d6a1d78b2defb6f985947f9429d912a083b9941ee30b1e53ef32890d19e94158 SHA512 ad608016d7785a735a28ea18f697be4882da747e3da32e4a7c7be4bf846d37e4d3374d78e62ef85607ae9f3f73ee35dc78b473347e4110c059a504be2c497c6e
diff --git a/dev-python/mako/files/mako-1.1.1-pypy3-test.patch b/dev-python/mako/files/mako-1.1.1-pypy3-test.patch
deleted file mode 100644
index 6ae5c04ab997..000000000000
--- a/dev-python/mako/files/mako-1.1.1-pypy3-test.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 5559e0205c7fbf2f4a321a978249a41c1d073278 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Fri, 21 Feb 2020 19:03:29 +0100
-Subject: [PATCH] Skip broken test on PyPy3
-
----
- test/test_exceptions.py | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/test/test_exceptions.py b/test/test_exceptions.py
-index 2ec46cf..6a30b48 100644
---- a/test/test_exceptions.py
-+++ b/test/test_exceptions.py
-@@ -1,5 +1,6 @@
- # -*- coding: utf-8 -*-
- import sys
-+import unittest
-
- from mako import compat
- from mako import exceptions
-@@ -429,6 +430,7 @@ ${foo()}
- else:
- assert False
-
-+ @unittest.skipIf(hasattr(sys, 'pypy_version_info'), 'Broken on pypy3')
- def test_alternating_file_names(self):
- l = TemplateLookup()
- l.put_string(
---
-2.25.1
-
diff --git a/dev-python/mako/mako-1.1.6.ebuild b/dev-python/mako/mako-1.1.6.ebuild
deleted file mode 100644
index c5fb4ab717f6..000000000000
--- a/dev-python/mako/mako-1.1.6.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-MY_P=${P^}
-DESCRIPTION="A Python templating language"
-HOMEPAGE="https://www.makotemplates.org/ https://pypi.org/project/Mako/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc"
-
-RDEPEND=">=dev-python/markupsafe-0.9.2[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}"/mako-1.1.1-pypy3-test.patch
-)
-
-distutils_enable_tests pytest
-
-python_install_all() {
- rm -r doc/build || die
-
- use doc && local HTML_DOCS=( doc/. )
- distutils-r1_python_install_all
-}