summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cachelib/Manifest1
-rw-r--r--dev-python/cachelib/cachelib-0.13.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/cachelib/Manifest b/dev-python/cachelib/Manifest
index 5c504c9291ed..056183421786 100644
--- a/dev-python/cachelib/Manifest
+++ b/dev-python/cachelib/Manifest
@@ -1 +1,2 @@
DIST cachelib-0.12.0.gh.tar.gz 30768 BLAKE2B 5d147e63d0be58c7134f851cea79a002aa89b5364aec5c0e0906bfb9573578b094d71f361265b15eb519da897eed069d4aaeae1a8599176a95c074186018a713 SHA512 a35bfa9dfb6db8ae0e6fcdad86e5221d82144d5c0fcdb046b951d193f70f706712800b27c27825f8020314c521eb568131257ce0e20dc820cb3f7f8ffbf2650f
+DIST cachelib-0.13.0.gh.tar.gz 31116 BLAKE2B fcb5f065778533bbe9200c77f12d374a62111c5dc26e366c07ea0986bba138a97c56de0440dd3b4a5603b8700ec8035b65ebe95d48e4dcf60c03f78a2215f128 SHA512 6b58f3823d1169ca1e25a5accc7a51752e26c8e7f62b58a571b0de4d8792dd6c3eb3d3c60f3843653b7aaa17177a1d6d56e442ceb6b69a486d76511003ff97b2
diff --git a/dev-python/cachelib/cachelib-0.13.0.ebuild b/dev-python/cachelib/cachelib-0.13.0.ebuild
new file mode 100644
index 000000000000..faaba7e5c123
--- /dev/null
+++ b/dev-python/cachelib/cachelib-0.13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of cache libraries in the same API interface. Extracted from werkzeug"
+HOMEPAGE="
+ https://pypi.org/project/cachelib/
+ https://github.com/pallets-eco/cachelib/
+"
+SRC_URI="
+ https://github.com/pallets-eco/cachelib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
+ net-misc/memcached
+ www-servers/uwsgi[python,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # bug #818523
+ tests/test_redis_cache.py
+ # requires some test server running
+ # (these tests require dev-python/boto3)
+ tests/test_dynamodb_cache.py
+ # requires mongo test server
+ tests/test_mongodb_cache.py
+)