summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysvn/Manifest1
-rw-r--r--dev-python/pysvn/pysvn-1.9.15.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pysvn/Manifest b/dev-python/pysvn/Manifest
index deee675c45e1..a1a1a103ecc7 100644
--- a/dev-python/pysvn/Manifest
+++ b/dev-python/pysvn/Manifest
@@ -1,2 +1,3 @@
DIST pysvn-1.9.11.tar.gz 624408 BLAKE2B 2ca13388717cc82b68509843e3b1780bceb5c088c41fadc81206c909eb185ec7c73d0a7453fc4e0c1a78a5186e21d382c79af0fb666edce7f5e72c0cf63e25db SHA512 078dc0e19a1f29d40571de002734943415594bcbe132a4d0e6bf8e8781175345ca1b3a4967a183a15efb1462871a40d8e3879a22c913a649555ca593fb99db89
DIST pysvn-1.9.13.tar.gz 666722 BLAKE2B 4ada83f474026976309b8fc7876dd860fb68eb73dd0a4db0dd0c2838cc029976d5886462705c8b6aa85c5a6f8081f94df61bcbc1698879537fbeb3125154c1a0 SHA512 26ce9af363efb1aee25f8ed73e5bab56208523cb3e7cbe657a5f1145bc3500b2f370b4dfebf4eaace9f566f5676b053c41acb4d01458e4d6b79bd852ac260aa7
+DIST pysvn-1.9.15.tar.gz 667161 BLAKE2B 35e9e0967d5c0b4cebf546e40df17b66c66406d0f8100c32e6e840220f60b0083c0ed3f3af5f54e2264d06905ea90970d6b7cbfad2bab872a14d5d4aea5900df SHA512 0809507134fd31f6bcc90217e7840eb166e2eb2ed56316010a549dd70f6f855599f596942574343cdefd5997947b12c847df2cd145669f50aa93f603e46a5ee0
diff --git a/dev-python/pysvn/pysvn-1.9.15.ebuild b/dev-python/pysvn/pysvn-1.9.15.ebuild
new file mode 100644
index 000000000000..9e8fecfbe0e4
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.9.15.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_IN_SOURCE_BUILD=true
+DISTUTILS_USE_SETUPTOOLS=bdepend # see setup.py
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="https://pysvn.sourceforge.io/"
+SRC_URI="mirror://sourceforge/project/pysvn/pysvn/V${PV}/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="
+ >=dev-python/pycxx-7.0.2[${PYTHON_USEDEP}]
+ >=dev-vcs/subversion-1.9"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ # Don't use internal copy of dev-python/pycxx.
+ rm -r Import || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ cd Source || die
+ # all config options from 1.7.6 are all already set
+ esetup.py configure
+}
+
+python_compile() {
+ cd Source || die
+ emake \
+ CC="$(tc-getCC)" \
+ CCC="$(tc-getCXX)"
+}
+
+python_test() {
+ cd Tests || die
+ emake
+}
+
+python_install() {
+ cd Source || die
+ python_domodule pysvn
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Docs/. )
+ if use examples; then
+ docinto examples
+ dodoc -r Examples/Client/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}