summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygccxml/Manifest2
-rw-r--r--dev-python/pygccxml/metadata.xml13
-rw-r--r--dev-python/pygccxml/pygccxml-1.0.0.ebuild37
-rw-r--r--dev-python/pygccxml/pygccxml-1.7.5.ebuild39
4 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/pygccxml/Manifest b/dev-python/pygccxml/Manifest
deleted file mode 100644
index 6f3155ac9b1c..000000000000
--- a/dev-python/pygccxml/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST pygccxml-1.0.0.zip 21639068 BLAKE2B 7ea93921485553f635e845e4261fcca7b995de54135ee87ca48f72c1f0bad151ac74097567e0635845bbf7d9fed09f673bf40a3c6e6ad32de97d5acf63d363cc SHA512 d2a96b5bb27c3620527839051e43fa1eee8884692707a347c76863ff44a04502dcff35fe18b95a35c32fb8a4935ed8d5d91bf41eb98aee74f6df08c48ddc0b67
-DIST pygccxml-1.7.5.tar.gz 3150295 BLAKE2B 69600641098aede52493cca2282464230602c4e329ba47c467993a2a6b0a2fa99ff100541dc8b6e8bdcb207a1906569a364ebf3917f35db1cd884ddbc5c4c02a SHA512 f76e1748646beaf1b16bd498026e177008f5ebe19e4b35ce612bb27f4f9e6174cdfe4459771adbc657b95e8d5edeea0687756f9ba82cabc10703043c4a7e6e1e
diff --git a/dev-python/pygccxml/metadata.xml b/dev-python/pygccxml/metadata.xml
deleted file mode 100644
index 29fca4f45351..000000000000
--- a/dev-python/pygccxml/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>heroxbd@gentoo.org</email>
- <name>Benda Xu</name>
- </maintainer>
- <longdescription>pygccxml is an object oriented framework for reading C++ declarations.</longdescription>
- <upstream>
- <remote-id type="sourceforge">pygccxml</remote-id>
- <remote-id type="github">gccxml/pygccxml</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pygccxml/pygccxml-1.0.0.ebuild b/dev-python/pygccxml/pygccxml-1.0.0.ebuild
deleted file mode 100644
index c8385483e97d..000000000000
--- a/dev-python/pygccxml/pygccxml-1.0.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Generate an XML description of a C++ program from GCC's internal representation"
-HOMEPAGE="http://www.language-binding.net/"
-SRC_URI="mirror://sourceforge/pygccxml/${P}.zip"
-
-LICENSE="freedist Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-DEPEND="
- app-arch/unzip
- doc? ( >=dev-python/epydoc-3[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-cpp/gccxml-0.6"
-
-python_compile_all() {
- use doc && esetup.py doc
-}
-
-python_test() {
- "${PYTHON}" unittests/test_all.py
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/apidocs/. )
- use examples && local EXAMPLES=( docs/example/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pygccxml/pygccxml-1.7.5.ebuild b/dev-python/pygccxml/pygccxml-1.7.5.ebuild
deleted file mode 100644
index 6ed3676182ec..000000000000
--- a/dev-python/pygccxml/pygccxml-1.7.5.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Generate an XML description of a C++ program from GCC's internal representation"
-HOMEPAGE="https://github.com/gccxml/pygccxml"
-SRC_URI="https://github.com/gccxml/pygccxml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="freedist Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="
- app-arch/unzip
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-cpp/gccxml-0.6"
-
-python_compile_all() {
- use doc && emake html man
-}
-
-python_test() {
- "${PYTHON}" unittests/test_all.py
-}
-
-python_install_all() {
- if use doc ; then
- local HTML_DOCS=( docs/_build/html )
- doman docs/_build/man/${PN}.1
- fi
-
- distutils-r1_python_install_all
-}