summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyproject-fmt/Manifest1
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-1.4.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 7bde2dc8b8ab..d10c79e4e923 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1,3 +1,4 @@
DIST pyproject_fmt-1.1.0.tar.gz 14219 BLAKE2B 9b5180edab6f1f0684d1bc5a503321f09d59acfc71e2f98a36c2b974f95a3f6c0309d43e2a87cbb0c9249d3bc0f74f0696dd3965d9fd2c8329441a2f20fcafea SHA512 dc18e19b7140bfe7a97e1b9720d493327f9006fb666130438b0ef670a91480e2faaad9ff951d42b8856044d028b725ec3b6a522084b7090208df5c853cefc78c
DIST pyproject_fmt-1.2.0.tar.gz 14304 BLAKE2B 7d7c469b5e5156097bdc176aa874338b4f848c8a2fb20bee3467d4267a60a6942c4bb512bebd1aa8abbe53349df9a899e9e0e9c27e2298f22d77ffca181af134 SHA512 368a29ca91052f51551ac3d0c707994fc9ba77ee5854460880164aafec9d92dd28d2950644cbda8760ce6396076ec9f3a034444e11cf0f59c6822cf2b6253f68
DIST pyproject_fmt-1.3.0.tar.gz 14367 BLAKE2B 55e96febd3b0bf9a84013c9ca002b7f77c043a62dae1dfc993efcabfe349bf607ffc23ba969c213e15debcd9e13cfe65267c14fa1a144f311fd20f14c043fd4c SHA512 d3e853e0f7c85ddffcc7ec2aa94d7f61fff2e55cbf6f564fd3b4bb1cf02d2dc54407b550d44dfefbfdd496f1b3ea995197cc3d45aea7725799abff12ccadcf0a
+DIST pyproject_fmt-1.4.1.tar.gz 15280 BLAKE2B e91fd5b5a5c6b1e26337446488107cce5441ad53dec5c74e04b991d844c37cd142644b2213353a11ddb8865b517652c0d1a25b67b2696ad3af3a0de8ce0c2e3b SHA512 4750340ddea29a214abb20bbddda2ff505f2b022812c7a9ddfd92edfb38315376757c5263f7f1a272867665af8f176ba3fefd1a1c210ee5ce5577ba2e9a4807b
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-1.4.1.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-1.4.1.ebuild
new file mode 100644
index 000000000000..c440d098979a
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-1.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+"
+# tox is called as a subprocess, to get targets from tox.ini
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # upstream lower bounds are completely meaningless and copying them
+ # to the ebuild is a horrible waste of time
+ sed -i -e 's:>=[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}