summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/colorful/Manifest1
-rw-r--r--dev-python/colorful/colorful-0.5.5.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/colorful/Manifest b/dev-python/colorful/Manifest
index 5927f9137a9c..880f11dbda60 100644
--- a/dev-python/colorful/Manifest
+++ b/dev-python/colorful/Manifest
@@ -1,2 +1 @@
-DIST colorful-0.5.5.gh.tar.gz 366498 BLAKE2B a7ab5dfb7ddfbf6682b75d2ed35f3f4cb7c3826918742316d877a17cb58e639b5fa86d7906be4879e89a5a0e78a16ede7535ade3f9f890c67bfcf42a0d1c9d9c SHA512 dc5e372261bd308a82bd0446a885b4c63a5a5781540731407f1a364d2c5397fe950f96fef3be8ffeab80cf02010be9551ba5b8550930e3fed5173cdc28a69306
DIST colorful-0.5.6.gh.tar.gz 366563 BLAKE2B b2c1b9b12bc5de69465ffaca9178c5ac56e0026b0ef732ab4a3a82286fd16141ec3ca397625fd00a3d041de41b34baadf1aacb185089ab0e8d5efddb7363418a SHA512 265e36c73a7ec183e4fd87d3db718b1bae353a99185eb4b1b5e057a6eda502b65672a3f0f9a569c76e6bf9342a1e2ee47fd2f4a8eaa08585f9806aa75c850661
diff --git a/dev-python/colorful/colorful-0.5.5.ebuild b/dev-python/colorful/colorful-0.5.5.ebuild
deleted file mode 100644
index 35e9e56ee19c..000000000000
--- a/dev-python/colorful/colorful-0.5.5.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Terminal string styling done right, in Python"
-HOMEPAGE="
- https://pypi.org/project/colorful/
- https://github.com/timofurrer/colorful/
-"
-SRC_URI="
- https://github.com/timofurrer/colorful/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # Fix QA_issue python package discovery
- # https://github.com/timofurrer/colorful/pull/53
- sed -i \
- -e "s/find_packages/find_namespace_packages/" \
- -e "s/(exclude=\['\*tests\*'\])/(exclude=\['\*tests\*'\, '\*examples\*'\])/" \
- setup.py || die "Error fixing setup.py for >=PEP420"
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -s
-}