summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-5.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index 89fc275a80d4..967bbc983e57 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1 +1,2 @@
DIST tempora-5.1.0.tar.gz 20402 BLAKE2B 8dcb70dd1491228c9f7daeda40a07e07236fa4f4aa8ad76ecb9514b922732468cbf4360726421420ce8478bba2287815a1473c5231afae82bda222a7401478e2 SHA512 33b48884c024f82e3220c2cc28a307bbb3c813a895df82640b5627266355c78cced3e5ab61df9b0619bf9697e18d70390939189ba31dd57c58fbb3e97b5db216
+DIST tempora-5.2.0.tar.gz 20775 BLAKE2B 3348e9899ce2e8867b334bf66e692ab79decd3c3b1aa572709d65346c37eb334eabbe905a50d4c73dda8844ca7ee6437f8f78320c8084fac06f32c30d51eee2e SHA512 66ac6319f1e62a003125c00af2a520fa6f60e57541dccee9d57348b51404fa0736e0ff2deaea0cc903434ae76e22bbe674b69235cd388fb50fa1cbc41d55681d
diff --git a/dev-python/tempora/tempora-5.2.0.ebuild b/dev-python/tempora/tempora-5.2.0.ebuild
new file mode 100644
index 000000000000..9651b023fc60
--- /dev/null
+++ b/dev-python/tempora/tempora-5.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest