summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pydantic-core/Manifest1
-rw-r--r--dev-python/pydantic-core/pydantic-core-2.16.1.ebuild151
2 files changed, 152 insertions, 0 deletions
diff --git a/dev-python/pydantic-core/Manifest b/dev-python/pydantic-core/Manifest
index eca8aae845c0..a7bba9870674 100644
--- a/dev-python/pydantic-core/Manifest
+++ b/dev-python/pydantic-core/Manifest
@@ -55,6 +55,7 @@ DIST pydantic_core-2.14.5.tar.gz 360131 BLAKE2B 00385297c5a16b7a11c0d219b58f954f
DIST pydantic_core-2.14.6.tar.gz 360305 BLAKE2B e9e9469c6e17833660b3b6af5bf2e575fb10a8abb47c80a9a4490ea2fc69d0af4006d044ca45f5227ea0d71d4ecab00ffab9470dcbf2de9f130068568e0f93f4 SHA512 c5215ff9915d420e367dcefcec656fdc17c4782b672f33d4532c5d43b8119626298258b7540fb471b46ad7906c5930ca4887f11ecc7104c89fc746e3ed0b3b43
DIST pydantic_core-2.15.0.tar.gz 364369 BLAKE2B df2044e96693db897328e6f73834ed439f0b3fab27e60c8f2f4300668cecfa3b7063c5fa820aa45e59b2e32d557843f2b72b5ff556d4667febfbcad0a7a7e2d2 SHA512 68f05f08cb7a089a8c8279f33c1339537828508af7dff89b623080301e8be6d7c12ce3a1ad87b79388e224e0338af841dab99b77ecc239d519e46682f0e49642
DIST pydantic_core-2.16.0.tar.gz 367651 BLAKE2B bb6a876616d22378f85505b15f15c7303cd99265970e4853c2721e2dfd8026cf106e0626c7b23b4cc4e3b6a220c01b4b81cf94c9089c51b5ada88d730ef8a93c SHA512 8a08c1f3a30364a5285a48692273160ce11755bfeea620a96eb1f5a1b7e1918ffbad217a13dfe57819dbce9dc8f83c70681f99988f40530324dfea84115c4c17
+DIST pydantic_core-2.16.1.tar.gz 368201 BLAKE2B 59c411f606fa1ad3177fe25f44593b957532698482d7b4df275de1a5ce6224bf1cdaf7769811c6716a2af7d6eef780df14336a1a1a5ad2bf18a18f09e318ba22 SHA512 96949c6cf55b940398e7c0b8f7848b627a7e6fc50d7141cf54a38b9201ff33be0475b4cbed9b670fa5085a0dc452e03cf1cb0541ba03132c1e5c95bf2b2ed16c
DIST pyo3-0.19.2.crate 418228 BLAKE2B ee018b33383fada78cd22643aea9231a8c8a2f19d1eb297f40eec9206c5220f322fff4c926d939a93a24ac6d231a207ebb25afcc0709191151c7ed9af7465efa SHA512 58698183e0f2f0507f8f765bf3e90185c933e78d62f0a9be65c4b1ce8eea19a98fe0341abe7c58cafdacb63a012ec417876dccb7be6facc1360fcb22796fcaf9
DIST pyo3-0.20.0.crate 431766 BLAKE2B 104bc21ce2c6931753ca0c7b2d91693f454c964260ca3c4628a899fc8e7edbe4238db913ed7356f3beff154d88a60a17c0e252b655768e75483e1d9d9b86f40b SHA512 85d9533c75f905752c62f6a4898582ae48daf085e287b44949c47260301205a5f00477927877ce46300d2801d22fbc04a958c058a37eb28374c834fff27feca1
DIST pyo3-0.20.1.crate 434263 BLAKE2B 8cd52f6dcdbfc4968dfc82bbeba54a6c7b8b5ff2410500f9862060c3836b2ae7fed3973ac4cc5fc9aaed382e1cd266c38ab0524230609271c79df23dc2b8c684 SHA512 f49a8570b4ed535ef6ac209b080e0612e1185babc2436aa488e29aecb7abcecc12ccf2214225ac17ef38c6c38d343dc8c2a186890e795b81c59ccf2a2ec8509e
diff --git a/dev-python/pydantic-core/pydantic-core-2.16.1.ebuild b/dev-python/pydantic-core/pydantic-core-2.16.1.ebuild
new file mode 100644
index 000000000000..0800803736aa
--- /dev/null
+++ b/dev-python/pydantic-core/pydantic-core-2.16.1.ebuild
@@ -0,0 +1,151 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=maturin
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+CRATES="
+ ahash@0.8.7
+ aho-corasick@1.0.2
+ allocator-api2@0.2.16
+ autocfg@1.1.0
+ base64@0.21.7
+ bitflags@1.3.2
+ cc@1.0.79
+ cfg-if@1.0.0
+ enum_dispatch@0.3.12
+ equivalent@1.0.1
+ form_urlencoded@1.2.1
+ getrandom@0.2.10
+ hashbrown@0.14.3
+ heck@0.4.1
+ idna@0.5.0
+ indexmap@2.0.0
+ indoc@2.0.4
+ itoa@1.0.8
+ jiter@0.0.6
+ lexical-core@0.8.5
+ lexical-parse-float@0.8.5
+ lexical-parse-integer@0.8.6
+ lexical-util@0.8.5
+ lexical-write-float@0.8.5
+ lexical-write-integer@0.8.5
+ libc@0.2.147
+ lock_api@0.4.10
+ memchr@2.6.3
+ memoffset@0.9.0
+ num-bigint@0.4.4
+ num-integer@0.1.45
+ num-traits@0.2.16
+ once_cell@1.18.0
+ parking_lot@0.12.1
+ parking_lot_core@0.9.8
+ percent-encoding@2.3.1
+ proc-macro2@1.0.76
+ pyo3-build-config@0.20.2
+ pyo3-ffi@0.20.2
+ pyo3-macros-backend@0.20.2
+ pyo3-macros@0.20.2
+ pyo3@0.20.2
+ python3-dll-a@0.2.9
+ quote@1.0.35
+ redox_syscall@0.3.5
+ regex-automata@0.4.3
+ regex-syntax@0.8.2
+ regex@1.10.2
+ rustversion@1.0.13
+ ryu@1.0.14
+ scopeguard@1.1.0
+ serde@1.0.195
+ serde_derive@1.0.195
+ serde_json@1.0.109
+ smallvec@1.11.2
+ speedate@0.13.0
+ static_assertions@1.1.0
+ strum@0.25.0
+ strum_macros@0.25.3
+ syn@2.0.48
+ target-lexicon@0.12.9
+ tinyvec@1.6.0
+ tinyvec_macros@0.1.1
+ unicode-bidi@0.3.13
+ unicode-ident@1.0.10
+ unicode-normalization@0.1.22
+ unindent@0.2.3
+ url@2.5.0
+ uuid@1.6.1
+ version_check@0.9.4
+ wasi@0.11.0+wasi-snapshot-preview1
+ windows-targets@0.48.1
+ windows_aarch64_gnullvm@0.48.0
+ windows_aarch64_msvc@0.48.0
+ windows_i686_gnu@0.48.0
+ windows_i686_msvc@0.48.0
+ windows_x86_64_gnu@0.48.0
+ windows_x86_64_gnullvm@0.48.0
+ windows_x86_64_msvc@0.48.0
+ zerocopy-derive@0.7.32
+ zerocopy@0.7.32
+"
+
+inherit cargo distutils-r1 pypi
+
+DESCRIPTION="Core validation logic for pydantic written in Rust"
+HOMEPAGE="
+ https://github.com/pydantic/pydantic-core/
+ https://pypi.org/project/pydantic-core/
+"
+SRC_URI+="
+ ${CARGO_CRATE_URIS}
+"
+
+LICENSE="MIT"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0-with-LLVM-exceptions MIT Unicode-DFS-2016
+ || ( Apache-2.0 Boost-1.0 )
+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=virtual/rust-1.70.0
+ test? (
+ >=dev-python/dirty-equals-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-6.63.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.10.4[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2022.7.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/pydantic_core/_pydantic_core.*.so"
+
+src_prepare() {
+ sed -i -e '/--benchmark/d' pyproject.toml || die
+ sed -i -e '/^strip/d' Cargo.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/benchmarks
+ )
+ local EPYTEST_DESELECT=(
+ # TODO: recursion till segfault
+ tests/serializers/test_functions.py::test_recursive_call
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf pydantic_core || die
+ epytest -p pytest_mock -p timeout
+}