summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests-mock/Manifest3
-rw-r--r--dev-python/requests-mock/requests-mock-1.8.0.ebuild46
-rw-r--r--dev-python/requests-mock/requests-mock-1.9.0.ebuild45
-rw-r--r--dev-python/requests-mock/requests-mock-1.9.1.ebuild45
4 files changed, 0 insertions, 139 deletions
diff --git a/dev-python/requests-mock/Manifest b/dev-python/requests-mock/Manifest
index ca5493fbc992..7cd4619f269e 100644
--- a/dev-python/requests-mock/Manifest
+++ b/dev-python/requests-mock/Manifest
@@ -1,5 +1,2 @@
-DIST requests-mock-1.8.0.tar.gz 59794 BLAKE2B 2bdcd180ea793a02cf34eda356d90c0e338cec6f3fb718564026d28ea06ac975073f291be9cb685f012c803fdeca1fe29139537529e292b91a3356f0b781f97a SHA512 252bce965e0fca03cd5ce09912c726045f9c632e90bfee13b06c9f3e2c6b70eab7f39cf8e7efb3b7d2cf2b5d79cc5c5ba6e2379b3d48ce33bf78861ada911918
-DIST requests-mock-1.9.0.tar.gz 66243 BLAKE2B 33602e85376d7812b8f4b35bf657c905ddc7db4d85e3de1f70d38871c90c42fc886e99bce3dc45079b6c8ac8e3e6b0b5291d4acda31d26045396d4ed505c3faf SHA512 1382077357a13dbec65cc4226b628ff6b55348422d9f0e9e2311c85affbc40437d22c2f95fa305303a86decc765a6228366f27eea76e254da194789b1d8fb610
-DIST requests-mock-1.9.1.tar.gz 66782 BLAKE2B 5457d359bf93f3f1e335481e44c1e9a391ee88c648b3c385806274e2c39ae3a69268d792dfc2e4609f2ccebd47dc2a3bb488f11b1b479c010a4194fe5cdc3be6 SHA512 96a8a787daa7d42796baf2807543ca18c27f595e101fd230cd392eb2417b3b0925b977a6fc49d70e21362e5b647cac201cb9f3968301ce2702772ddd85cf7094
DIST requests-mock-1.9.2.tar.gz 67383 BLAKE2B 70a0772b415f437c38897862d663983d9ac65a5fc37d70b4f8734f8c249457dab6c4b1c04db79f7865a9b31a49aaa9cbbee98453ea5bcda35aad2e7cd9ca3f4a SHA512 b8da389f6642a4dfaac77b2613d12e3028555a5d4154aa7252e50fef527a49fb78d85dbd911ad2fd7d5ebc0efa49a2c0fd8d3b10114596839f0ddb53d917773c
DIST requests-mock-1.9.3.tar.gz 67988 BLAKE2B 8ab651adbde9e18370641655589f5d209d2a9ae07d82108c64e4269757217cf01588066ebc3005852cf48527f911d3fb76cedce3e88bc74123db81725b4b5865 SHA512 bcded541d78670a1b1fc87f97d35286ab4bafd6946beb9d9b44886454c26a4d8c05834add18914f3f72b1d3c0534311efd1cc80e711b5085eb63053ae24cbb6f
diff --git a/dev-python/requests-mock/requests-mock-1.8.0.ebuild b/dev-python/requests-mock/requests-mock-1.8.0.ebuild
deleted file mode 100644
index 148512ff7544..000000000000
--- a/dev-python/requests-mock/requests-mock-1.8.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Mock out responses from the requests package"
-HOMEPAGE="https://github.com/jamielennox/requests-mock"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-
-RDEPEND="
- >=dev-python/requests-2.3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
- test? (
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx doc/source
-distutils_enable_tests unittest
-
-python_prepare_all() {
- # Disable reno which only works inside a git repository
- sed -i "s/'reno.sphinxext',//" doc/source/conf.py || die
- # Remove the release notes section which requires reno
- rm doc/source/release-notes.rst || die
- sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
- # Disable a test which requires purl (not in the tree)
- sed -i -e "/^import purl$/d" -e "s/test_with_purl/_&/" \
- tests/test_adapter.py || die
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/requests-mock/requests-mock-1.9.0.ebuild b/dev-python/requests-mock/requests-mock-1.9.0.ebuild
deleted file mode 100644
index 930d9082097b..000000000000
--- a/dev-python/requests-mock/requests-mock-1.9.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Mock out responses from the requests package"
-HOMEPAGE="https://github.com/jamielennox/requests-mock"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-
-RDEPEND="
- >=dev-python/requests-2.3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
- test? (
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx doc/source
-distutils_enable_tests unittest
-
-python_prepare_all() {
- # Disable reno which only works inside a git repository
- sed -i "s/'reno.sphinxext',//" doc/source/conf.py || die
- # Remove the release notes section which requires reno
- rm doc/source/release-notes.rst || die
- sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
- # Disable a test which requires purl (not in the tree)
- sed -i -e "/^import purl$/d" -e "s/test_with_purl/_&/" \
- tests/test_adapter.py || die
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/requests-mock/requests-mock-1.9.1.ebuild b/dev-python/requests-mock/requests-mock-1.9.1.ebuild
deleted file mode 100644
index 930d9082097b..000000000000
--- a/dev-python/requests-mock/requests-mock-1.9.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Mock out responses from the requests package"
-HOMEPAGE="https://github.com/jamielennox/requests-mock"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-
-RDEPEND="
- >=dev-python/requests-2.3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
- test? (
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx doc/source
-distutils_enable_tests unittest
-
-python_prepare_all() {
- # Disable reno which only works inside a git repository
- sed -i "s/'reno.sphinxext',//" doc/source/conf.py || die
- # Remove the release notes section which requires reno
- rm doc/source/release-notes.rst || die
- sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
- # Disable a test which requires purl (not in the tree)
- sed -i -e "/^import purl$/d" -e "s/test_with_purl/_&/" \
- tests/test_adapter.py || die
- distutils-r1_python_prepare_all
-}