summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-49.6.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index fbb33422f695..186d7ec1f0d9 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -7,3 +7,4 @@ DIST setuptools-49.3.0.zip 2175616 BLAKE2B bc46992660adbf5aeafa0c3e93c9fa598c6ec
DIST setuptools-49.3.1.zip 2175721 BLAKE2B 825fd23e504f2fc4d70c55435862e1080b20ea8d1d279b0d8934c12b9d793665161c07a43770fa2ad92dec7d405b04091d752f09bc2416e7239425dfc2f7e666 SHA512 57c3e31540b89c1356cc23a59c2c158b44a55a45ebc9c087a3a977af59ea387bb38baf54fd3b14ea23033715870a86b965c1828203f3df8b6cdad19fb4ea9249
DIST setuptools-49.3.2.zip 2175821 BLAKE2B d7160869528bc50085646b7c27e153e406ee0d98e2e5bba1241ea8ca6e07248651b5d54ee2e5cf040858533c1fec6f4b6ffb77ad3f130fd12611ce6280c9adbb SHA512 4474b23a4f62fe5ac9f0b66a639be02da84c8abf22ad86f6436c02c82019f89a2ca14e8f8cbe9dd0932cfb32287a196d0a4735d709b301764bdb8b3d9da42c45
DIST setuptools-49.4.0.zip 2188110 BLAKE2B 7b31969425ba1200f390428eedef8e2406ec1d209ffefde0b090f0c0137871544623295e01a3b8c672222fca82def36fe638ea70571280ec0932bc9e631d83f8 SHA512 1abe2bc006e7212a6cdbd18fa4aafe1063855e2c39c837649b4ec07226a4bc0d870fa1d0e89660d0b61f793dec5f1c3e8984ff47ad4b39391c83868cb59556c5
+DIST setuptools-49.6.0.zip 2188590 BLAKE2B b789386d31c0d5cbc0c899d24e9af35baad371b698b488ed46b768e8831bae7245b391971e1e402799bc555475c1d8b78bd59a224c26bc78ba68b122a06e0154 SHA512 aad6e74b0e276da0f79c9429860a6d1c7860a30e9a02ce55527abbe7671366640423a1e5476da9ecadfc62ae1bf803cb0c664e2a09cf7619a9c8ac3965b9cf31
diff --git a/dev-python/setuptools/setuptools-49.6.0.ebuild b/dev-python/setuptools/setuptools-49.6.0.ebuild
new file mode 100644
index 000000000000..87b988937299
--- /dev/null
+++ b/dev-python/setuptools/setuptools-49.6.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ # xpass-es for me on py3
+ #sed -e '/xfail.*710/s:(:(six.PY2, :' \
+ # -i setuptools/tests/test_archive_util.py || die
+
+ # avoid pointless dep on flake8
+ sed -i -e 's:--flake8::' -e 's:--cov::' pytest.ini || die
+
+ # disable the code disabling non-existing coverage plugin
+ sed -i -e 's:cov = .*:return:' conftest.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}