summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/enzyme/enzyme-0.4.1-r3.ebuild4
-rw-r--r--dev-python/pycxx/pycxx-7.1.7-r1.ebuild4
-rw-r--r--dev-python/pycxx/pycxx-7.1.7.ebuild6
-rw-r--r--dev-python/pycxx/pycxx-7.1.8.ebuild4
-rw-r--r--dev-python/pysvn/pysvn-1.9.18.ebuild6
-rw-r--r--dev-python/pysvn/pysvn-1.9.22.ebuild4
-rw-r--r--dev-python/pythondialog/pythondialog-3.5.3.ebuild6
-rw-r--r--dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.8.ebuild4
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild4
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.18.6.ebuild2
-rw-r--r--dev-python/yapsy/yapsy-1.12.2-r2.ebuild4
11 files changed, 24 insertions, 24 deletions
diff --git a/dev-python/enzyme/enzyme-0.4.1-r3.ebuild b/dev-python/enzyme/enzyme-0.4.1-r3.ebuild
index 4e6a35b08544..0f7e8abfbfb8 100644
--- a/dev-python/enzyme/enzyme-0.4.1-r3.ebuild
+++ b/dev-python/enzyme/enzyme-0.4.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,7 @@ HOMEPAGE="
https://pypi.org/project/enzyme/
"
SRC_URI+="
- test? ( mirror://sourceforge/matroska/test_files/matroska_test_w1_1.zip )
+ test? ( https://downloads.sourceforge.net/matroska/test_files/matroska_test_w1_1.zip )
"
LICENSE="Apache-2.0"
diff --git a/dev-python/pycxx/pycxx-7.1.7-r1.ebuild b/dev-python/pycxx/pycxx-7.1.7-r1.ebuild
index cadfdbb9e765..8b27cd67cefd 100644
--- a/dev-python/pycxx/pycxx-7.1.7-r1.ebuild
+++ b/dev-python/pycxx/pycxx-7.1.7-r1.ebuild
@@ -3,7 +3,7 @@
EAPI="8"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
# DISTUTILS_USE_PEP517=setuptools broken, installs files to /usr/CXX
DISTUTILS_USE_SETUPTOOLS=no
@@ -11,7 +11,7 @@ inherit distutils-r1
DESCRIPTION="Set of facilities to extend Python with C++"
HOMEPAGE="http://cxx.sourceforge.net"
-SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/cxx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-python/pycxx/pycxx-7.1.7.ebuild b/dev-python/pycxx/pycxx-7.1.7.ebuild
index 520c93fdfd83..0ee747e851dc 100644
--- a/dev-python/pycxx/pycxx-7.1.7.ebuild
+++ b/dev-python/pycxx/pycxx-7.1.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
# DISTUTILS_USE_PEP517=setuptools broken, installs files to /usr/CXX
DISTUTILS_USE_SETUPTOOLS=no
@@ -11,7 +11,7 @@ inherit distutils-r1
DESCRIPTION="Set of facilities to extend Python with C++"
HOMEPAGE="http://cxx.sourceforge.net"
-SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/cxx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-python/pycxx/pycxx-7.1.8.ebuild b/dev-python/pycxx/pycxx-7.1.8.ebuild
index cadfdbb9e765..8b27cd67cefd 100644
--- a/dev-python/pycxx/pycxx-7.1.8.ebuild
+++ b/dev-python/pycxx/pycxx-7.1.8.ebuild
@@ -3,7 +3,7 @@
EAPI="8"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
# DISTUTILS_USE_PEP517=setuptools broken, installs files to /usr/CXX
DISTUTILS_USE_SETUPTOOLS=no
@@ -11,7 +11,7 @@ inherit distutils-r1
DESCRIPTION="Set of facilities to extend Python with C++"
HOMEPAGE="http://cxx.sourceforge.net"
-SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/cxx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-python/pysvn/pysvn-1.9.18.ebuild b/dev-python/pysvn/pysvn-1.9.18.ebuild
index e57b794b9f3b..c658b7e404a0 100644
--- a/dev-python/pysvn/pysvn-1.9.18.ebuild
+++ b/dev-python/pysvn/pysvn-1.9.18.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 toolchain-funcs
DESCRIPTION="Object-oriented python bindings for subversion"
HOMEPAGE="https://pysvn.sourceforge.io/"
-SRC_URI="mirror://sourceforge/project/pysvn/pysvn/V${PV}/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/project/pysvn/pysvn/V${PV}/${P}.tar.gz"
LICENSE="Apache-1.1"
SLOT="0"
diff --git a/dev-python/pysvn/pysvn-1.9.22.ebuild b/dev-python/pysvn/pysvn-1.9.22.ebuild
index f45e97bbd8c2..6e6d1762769f 100644
--- a/dev-python/pysvn/pysvn-1.9.22.ebuild
+++ b/dev-python/pysvn/pysvn-1.9.22.ebuild
@@ -3,14 +3,14 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 toolchain-funcs
DESCRIPTION="Object-oriented python bindings for subversion"
HOMEPAGE="https://pysvn.sourceforge.io/"
-SRC_URI="mirror://sourceforge/project/pysvn/pysvn/V${PV}/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/project/pysvn/pysvn/V${PV}/${P}.tar.gz"
LICENSE="Apache-1.1"
SLOT="0"
diff --git a/dev-python/pythondialog/pythondialog-3.5.3.ebuild b/dev-python/pythondialog/pythondialog-3.5.3.ebuild
index 694085c05663..0e1109ba8ba4 100644
--- a/dev-python/pythondialog/pythondialog-3.5.3.ebuild
+++ b/dev-python/pythondialog/pythondialog-3.5.3.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
inherit distutils-r1
DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
HOMEPAGE="https://pythondialog.sourceforge.io/"
-SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/python3-${P}.tar.bz2"
+SRC_URI="https://downloads.sourceforge.net/project/${PN}/${PN}/${PV}/python3-${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0"
diff --git a/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.8.ebuild b/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.8.ebuild
index d4042348b9f6..fd62c9fd61b4 100644
--- a/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.8.ebuild
+++ b/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ HOMEPAGE="
https://sourceforge.net/projects/ruamel-yaml-clib/
"
# sdist lacks .pyx files for cythonizing
-SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+SRC_URI="https://downloads.sourceforge.net/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
# workaround https://bugs.gentoo.org/898716
S=${WORKDIR}/ruamel_yaml_clib
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild
index 78b0ae605fe8..0b0839c508c1 100644
--- a/dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,7 @@ HOMEPAGE="
https://sourceforge.net/projects/ruamel-yaml/
"
# PyPI tarballs do not include tests
-SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+SRC_URI="https://downloads.sourceforge.net/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
S="${WORKDIR}"/${MY_P}
LICENSE="MIT"
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.18.6.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.18.6.ebuild
index c916f70d468e..6c7d0b943af2 100644
--- a/dev-python/ruamel-yaml/ruamel-yaml-0.18.6.ebuild
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.18.6.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="
https://sourceforge.net/projects/ruamel-yaml/
"
# PyPI tarballs do not include tests
-SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+SRC_URI="https://downloads.sourceforge.net/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
S="${WORKDIR}"/${MY_P}
LICENSE="MIT"
diff --git a/dev-python/yapsy/yapsy-1.12.2-r2.ebuild b/dev-python/yapsy/yapsy-1.12.2-r2.ebuild
index 5e176818e907..72591c69b739 100644
--- a/dev-python/yapsy/yapsy-1.12.2-r2.ebuild
+++ b/dev-python/yapsy/yapsy-1.12.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,7 +14,7 @@ HOMEPAGE="
https://github.com/tibonihoo/yapsy/
https://pypi.org/project/Yapsy/
"
-SRC_URI="mirror://sourceforge/yapsy/${MY_P}/${MY_P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/yapsy/${MY_P}/${MY_P}.tar.gz"
S=${WORKDIR}/${MY_P}
LICENSE="BSD"