summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pep8/Manifest2
-rw-r--r--dev-python/pep8/pep8-1.5.7.ebuild35
-rw-r--r--dev-python/pep8/pep8-1.7.0.ebuild37
3 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/pep8/Manifest b/dev-python/pep8/Manifest
index cc45297fb7b4..b715227ccb98 100644
--- a/dev-python/pep8/Manifest
+++ b/dev-python/pep8/Manifest
@@ -1,3 +1 @@
-DIST pep8-1.5.7.tar.gz 67302 BLAKE2B 714ecb7f21c457aca1a2465319c3f202d13b5cfe067418eb2e3e6f21b25dffbab891a05f5b145264e484c180b67e1fc8c4ad1cf47f1413ebeaff2bb858f9858e SHA512 ae5cc6cc47d71e90059fec0c89f5e8e7b71b08d185c95b0c8cf0aa9acaee4841d0cfc617fb1ca6d7af7f4721480a1992b6178dc845d80dfe87fe3792d515a3eb
-DIST pep8-1.7.0.tar.gz 79704 BLAKE2B f2e3585bdb3732f9be7f77b1cbf065c0938c1847a5caeb493e3cd62e6a5e19713779a087ffdc9c627481fb10e13d3ed53b3bc368182c2442f24ad57d1d2e96d3 SHA512 0077dac97846fe3a5fc654cd3ce8578845cf3b93ee097a3ae6ff2db4ae0797ad5766c69f036d6a5add786eb929a9beb6d657ab693227b8df2ba46ec0f9284b0a
DIST pep8-1.7.1.tar.gz 80334 BLAKE2B 71a038c8fbcbd7c94ff713d1eb8fa248106d283fb520f97fe35819b14382eff6e55683b739acd933cfe22001ed262f76a9b6f3f55661938b3b199ec1f4c35745 SHA512 d20d6a6f91bc865580e3d39c50e26f9c6be81fd8e80a1b9a029d7ea9c906748e46080b841dc5507004089e5ee0d0cb3f70a74bb35131c58113ff5571153af4da
diff --git a/dev-python/pep8/pep8-1.5.7.ebuild b/dev-python/pep8/pep8-1.5.7.ebuild
deleted file mode 100644
index f9590a261725..000000000000
--- a/dev-python/pep8/pep8-1.5.7.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python style guide checker"
-HOMEPAGE="https://github.com/jcrocholl/pep8 https://pypi.org/project/pep8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH="${S}" "${PYTHON}" pep8.py -v --testsuite=testsuite || die
- PYTHONPATH="${S}" "${PYTHON}" pep8.py --doctest -v || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pep8/pep8-1.7.0.ebuild b/dev-python/pep8/pep8-1.7.0.ebuild
deleted file mode 100644
index b777f1e6605a..000000000000
--- a/dev-python/pep8/pep8-1.7.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python style guide checker"
-HOMEPAGE="https://github.com/PyCQA/pep8 https://pypi.org/project/pep8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 s390 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH="${S}" "${PYTHON}" pep8.py -v --statistics pep8.py || die
- PYTHONPATH="${S}" "${PYTHON}" pep8.py -v --testsuite=testsuite || die
- PYTHONPATH="${S}" "${PYTHON}" pep8.py --doctest -v || die
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}