summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypdf/Manifest1
-rw-r--r--dev-python/pypdf/pypdf-3.15.4.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index e54d3d61d2d9..14908aa4ce33 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,4 +1,5 @@
DIST pypdf-3.15.1.gh.tar.gz 7679588 BLAKE2B 9148d17be47fc653bba26fc39ca58f503eba7fd561ef67be034f6ce18318069a1e981e46d6a23ff18dd20a9ddbd38ff056a17e63e71b253d851d3c3934057c74 SHA512 93a4c5c573f8db73df4dd113e4d502bb183c2548a556686848dabf46078721e583c0283f6148c268d6e502e25402fab7b5e40d3eb9c60ab4db19827f183636e5
DIST pypdf-3.15.2.gh.tar.gz 7679823 BLAKE2B c53e51adaa2d789b56f0871ef9937e01eb91074dd30afece840a17c8b789686ff88942345764e7451b4ad1af21405f9e18d96f03cb8cdfbbe34ef786fcd85fac SHA512 804ff4c57e626b10827167a91aaa82e9acc46aea48b1a961ea50fff526c3fc012aa231f2ea269bd715a9f5294b684f8338d34356f738dd45f512228019a63633
DIST pypdf-3.15.3.gh.tar.gz 7682634 BLAKE2B c0b4046152fecaaddab28e6c8220d001bb47cf958464f2e4c6507dd089810ad61ccbbf0922d592d190f3effc88ed0c0cf3331e634616e985aedc4a026d5e4f52 SHA512 8fc82cc204a807ab308b21c8665162710fd9a3fb58fd8177fe559b801247ad8a8c949ce58d2879b6b64c040d137eb6731a76b533308b30e556a59bd33ae6b12e
+DIST pypdf-3.15.4.gh.tar.gz 7929672 BLAKE2B da8bbbe6f1df51be63d116789eb4626ab59e576f52327a53e0d02eef38dcbe8d3524a3a33bc6b9103920fdc6322d75e5e82e76ad88c4166b5d13cb4bcda3ed0f SHA512 8d7db1c52700a2c9ec37c1756d04555708f4c859394c4866316d94470742a8d7900e5ec5d8fb2124ad285efc4848071d373347353226959b21dff84425b46513
DIST pypdf-sample-files-935652968f76a41b4fa51afd05498e7dd7314c5e.gh.tar.gz 11187445 BLAKE2B e9332009a49249fdaa8b6c29258b11dfcf3627a5550ea7402cf0288bb4b0537136b039e6f4aefb03574076d1fc0af6100effc0d36510f035d9e63836ad52c4d7 SHA512 8d525aa323e5b45f71130459faa9686ec4ae04bc594895a64f1a5b6d027f866c48aca78602ad526000a11b547cc77068d1ac5e733d3e3a99df0e257c02fbb9e7
diff --git a/dev-python/pypdf/pypdf-3.15.4.ebuild b/dev-python/pypdf/pypdf-3.15.4.ebuild
new file mode 100644
index 000000000000..bd9de5c7eff6
--- /dev/null
+++ b/dev-python/pypdf/pypdf-3.15.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=935652968f76a41b4fa51afd05498e7dd7314c5e
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ # TODO: requires fpdf
+ tests/test_page.py::test_compression
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ epytest -o addopts= -m "not enable_socket"
+}