summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch28
-rw-r--r--dev-python/slixmpp/slixmpp-1.7.1.ebuild10
-rw-r--r--dev-python/slixmpp/slixmpp-9999.ebuild6
3 files changed, 34 insertions, 10 deletions
diff --git a/dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch b/dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch
new file mode 100644
index 000000000000..0901090e4651
--- /dev/null
+++ b/dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch
@@ -0,0 +1,28 @@
+From 8b7648502b003d433a08333b041baf1d4960c9d4 Mon Sep 17 00:00:00 2001
+From: Nicolas Cedilnik <nicoco@nicoco.fr>
+Date: Mon, 22 Feb 2021 13:07:15 +0100
+Subject: [PATCH] Fix deprecation warning
+
+---
+ slixmpp/thirdparty/orderedset.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/slixmpp/thirdparty/orderedset.py b/slixmpp/thirdparty/orderedset.py
+index f6642db3..43023af4 100644
+--- a/slixmpp/thirdparty/orderedset.py
++++ b/slixmpp/thirdparty/orderedset.py
+@@ -20,9 +20,9 @@
+ # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ # OTHER DEALINGS IN THE SOFTWARE.
+
+-import collections
++from collections.abc import MutableSet
+
+-class OrderedSet(collections.MutableSet):
++class OrderedSet(MutableSet):
+
+ def __init__(self, iterable=None):
+ self.end = end = []
+--
+GitLab
+
diff --git a/dev-python/slixmpp/slixmpp-1.7.1.ebuild b/dev-python/slixmpp/slixmpp-1.7.1.ebuild
index 19974e840958..e37f059d7d37 100644
--- a/dev-python/slixmpp/slixmpp-1.7.1.ebuild
+++ b/dev-python/slixmpp/slixmpp-1.7.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -31,8 +31,8 @@ RDEPEND="
${DEPEND}
"
-distutils_enable_tests unittest
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
-python_test() {
- "${EPYTHON}" ./run_tests.py || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests unittest
diff --git a/dev-python/slixmpp/slixmpp-9999.ebuild b/dev-python/slixmpp/slixmpp-9999.ebuild
index 0f5e88aa5f6c..4c7eb16a1e1b 100644
--- a/dev-python/slixmpp/slixmpp-9999.ebuild
+++ b/dev-python/slixmpp/slixmpp-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -32,7 +32,3 @@ RDEPEND="
"
distutils_enable_tests unittest
-
-python_test() {
- "${EPYTHON}" ./run_tests.py || die "Tests failed with ${EPYTHON}"
-}