summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jc/Manifest1
-rw-r--r--dev-python/jc/jc-1.18.7.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jc/Manifest b/dev-python/jc/Manifest
index 4b12ce66cdc5..d9396f17105e 100644
--- a/dev-python/jc/Manifest
+++ b/dev-python/jc/Manifest
@@ -1,2 +1,3 @@
DIST jc-1.18.5.tar.gz 3981643 BLAKE2B 9eebaef4e2ee0a014df5fa73f0fecf9d91c62483594d529d6ae9b1d538ee4c62ec1ab6f673f0f3fbb32220920c843e8fd6a487ecaaa9662b63128ff9df786dcc SHA512 f105aa3aa6e5059d06976d089f52eb9c8a1005e2b2c0b9ee2b4229e2f82028277a45979d34a6f81679c22472d7a99903711ac6946accdb86c796e790d121112e
DIST jc-1.18.6.tar.gz 4007477 BLAKE2B 9380e8a254df921983f486d8d9d0e8479e477e391075ace3fcaa40029f72b733abd6d55ed62f4cd436bb280fa37d9bdec6398418e24c714caa833fcef2991d35 SHA512 ae291ea271e12cebd1e0287cdc8e3f52c72959711d9da752880a1a90257b3add23c6a4b97d34ee0ebfa2332e355b90f8388cd425d18f03aa37c4979765101086
+DIST jc-1.18.7.tar.gz 8106032 BLAKE2B 05c069d0c00c1c789d253419dfc1e2caee656a848618b761664e7d46f87705f945955164c4fc213f7e8f19840b529d02ab52bc439384db122f3d464226c2b4b4 SHA512 c5ce538d4565f29a0d5fb1e39eda80a84481ad74c7ea4ce9339ec7881f2888a105af5c77c8adaf0b6174830e2f7cd1bf9628e5b9bb87d9c7b17e567251645ca9
diff --git a/dev-python/jc/jc-1.18.7.ebuild b/dev-python/jc/jc-1.18.7.ebuild
new file mode 100644
index 000000000000..989dcb9e4a0b
--- /dev/null
+++ b/dev-python/jc/jc-1.18.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="
+ https://github.com/kellyjonbrazil/jc/
+ https://pypi.org/project/jc/
+"
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest