summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/entrypoint2/Manifest1
-rw-r--r--dev-python/entrypoint2/entrypoint2-1.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/entrypoint2/Manifest b/dev-python/entrypoint2/Manifest
index 3bdb0bb2a058..5e0b8c117185 100644
--- a/dev-python/entrypoint2/Manifest
+++ b/dev-python/entrypoint2/Manifest
@@ -1 +1,2 @@
DIST entrypoint2-1.0.tar.gz 15424 BLAKE2B 1270a35218cde90922fe8f675917545f4c43e5ec0effd632583cd0bd02200d6a453716787c222722cec633bcb108c1b8c26e284e9659e754d3bc6a77895a6042 SHA512 6580dbf19482af95cbccad61b6f6dc73c068ac78d166e2cea4fae54243921e577316d38e204ad5983f0f52d898d67a10f4c90332d4eeaff1ea713bfc82c70890
+DIST entrypoint2-1.1.gh.tar.gz 15480 BLAKE2B e9a834b863e624971266b78fed75ce2621511f7529f88e4950803c8978a1e27e81585751c25eab82aa1507b6abf8500b11e6ab7ec80052ccd31bec16bf3ed790 SHA512 807b8a53cc5c3e88de971c624dc69b3d526637d84856a0a67fdf2d15c51224cb5c48a7614eaa1942783ce2e954791a86f5ae6eb4dbf1a6e7928161e2cc8f293d
diff --git a/dev-python/entrypoint2/entrypoint2-1.1.ebuild b/dev-python/entrypoint2/entrypoint2-1.1.ebuild
new file mode 100644
index 000000000000..0ad7d18b4367
--- /dev/null
+++ b/dev-python/entrypoint2/entrypoint2-1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Easy to use command-line interface for python modules"
+HOMEPAGE="https://github.com/ponty/entrypoint2"
+SRC_URI="
+ https://github.com/ponty/entrypoint2/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest