summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyotp/Manifest1
-rw-r--r--dev-python/pyotp/pyotp-2.7.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pyotp/Manifest b/dev-python/pyotp/Manifest
index 4d772d5cc534..629fd297af6a 100644
--- a/dev-python/pyotp/Manifest
+++ b/dev-python/pyotp/Manifest
@@ -1 +1,2 @@
DIST pyotp-2.6.0.tar.gz 15687 BLAKE2B 9e1b97c5fd5a3d9b335c173d44922a0427f9f49f4fb27579ee528d1e6f4776b33db31a1664a9bd6295bbec331458e17ac380c1fcd9860bc200577051f2af2e7e SHA512 8d650c6840dd243c4dcb522745ae80b462c1819bcafef226923d13be6a2b096cf5f2146829fd553d5e096d82b67725706d69d0cbb15a5d6586ea234201671bcd
+DIST pyotp-2.7.0.tar.gz 16709 BLAKE2B 83b565afe4b718185274682540ad41591913a710d6683c0131dd7a47c100514e6dfea20d432aed39ab80ec232122329206841c3e024290160a86c74e3e8b3f65 SHA512 e2d67de9a7e4a711d4d0037c2a52c05be5b0ecb5fc85f942a1b9a14b261300dff0058be2fe2d2829d351cf665a0d238d3602c27184f56f7886a9049120c4e44f
diff --git a/dev-python/pyotp/pyotp-2.7.0.ebuild b/dev-python/pyotp/pyotp-2.7.0.ebuild
new file mode 100644
index 000000000000..7491d02761fa
--- /dev/null
+++ b/dev-python/pyotp/pyotp-2.7.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords"
+HOMEPAGE="https://github.com/pyauth/pyotp
+ https://pypi.org/project/pyotp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest