summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-argparse/Manifest1
-rw-r--r--dev-python/sphinx-argparse/metadata.xml12
-rw-r--r--dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild22
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sphinx-argparse/Manifest b/dev-python/sphinx-argparse/Manifest
new file mode 100644
index 000000000000..78929c27d15f
--- /dev/null
+++ b/dev-python/sphinx-argparse/Manifest
@@ -0,0 +1 @@
+DIST sphinx_argparse-0.4.0.tar.gz 15020 BLAKE2B 73118f56ff82d52f04066b9d500aebc77eb5a0fecd03fa69f382c0f2afc0cbffdd395da707cf37b59f039e93935f8d5c3fe0e0f7a2820d3b6509dd78b37b0d74 SHA512 b96050da6c02f87c54f9dc9146bed955e99258df740b467575a2b3e9919fa8c4c6d30a736dab24360086bfc0d7d09c4bc7a818700af2c7846eed3a3b99053d65
diff --git a/dev-python/sphinx-argparse/metadata.xml b/dev-python/sphinx-argparse/metadata.xml
new file mode 100644
index 000000000000..34557e466493
--- /dev/null
+++ b/dev-python/sphinx-argparse/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ashb/sphinx-argparse</remote-id>
+ <remote-id type="pypi">sphinx-argparse</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild b/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild
new file mode 100644
index 000000000000..2b28e7ab59e5
--- /dev/null
+++ b/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension that automatically documents argparse commands and options"
+HOMEPAGE="https://pypi.org/project/sphinx-argparse/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest