summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/betamax/Manifest1
-rw-r--r--dev-python/betamax/betamax-0.8.1.ebuild32
-rw-r--r--dev-python/betamax/files/betamax-0.8.1-tests.patch20
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/betamax/Manifest b/dev-python/betamax/Manifest
index 7cc27cc1a78f..28dcf27a8db7 100644
--- a/dev-python/betamax/Manifest
+++ b/dev-python/betamax/Manifest
@@ -1 +1,2 @@
DIST betamax-0.8.0.tar.gz 78398 BLAKE2B cc9546eb028343621ef47a9cb7992f1d3eef4a2b6837cc8b670ff7d0313020def203ff06bf1e21c2d4ef26932df65e71562110b14bf27fc5c1a6ca3ba9023f54 SHA512 52b330747b6add52390b50dd63c05851adc01ccd238fdb5c3401efdfc26be363a3f61145dc0e1f3cc43ff520e1457e33fa47952d2929c7c3e12c3e2612621f95
+DIST betamax-0.8.1.tar.gz 77526 BLAKE2B 2ce88326c5ef80082908912c4b14f149793c4457c47446ebcabaaffaa6b0ee64528096acc6bdd868fce0fad3d10ad66697cad5dc422c15b324e1cc9ae20eafa6 SHA512 89bfb56cf4004a70ec8c1f2342cfa0e02f850b8ed80b67f8b2b02c1a2093e8ac1cf1b9980354551e9d3a21fadde0d77d717f1559487024941973cd80bd451734
diff --git a/dev-python/betamax/betamax-0.8.1.ebuild b/dev-python/betamax/betamax-0.8.1.ebuild
new file mode 100644
index 000000000000..8339084b5f6a
--- /dev/null
+++ b/dev-python/betamax/betamax-0.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="python-requests HTTP exchanges recorder"
+HOMEPAGE="https://github.com/sigmavirus24/betamax"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )"
+
+# Tests require Internet access
+RESTRICT=test
+
+PATCHES=(
+ "${FILESDIR}/betamax-0.8.1-tests.patch"
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/betamax/files/betamax-0.8.1-tests.patch b/dev-python/betamax/files/betamax-0.8.1-tests.patch
new file mode 100644
index 000000000000..19da7d108efd
--- /dev/null
+++ b/dev-python/betamax/files/betamax-0.8.1-tests.patch
@@ -0,0 +1,20 @@
+diff --git a/tests/unit/test_fixtures.py b/tests/unit/test_fixtures.py
+index 387d9ce..f0bdc3b 100644
+--- a/tests/unit/test_fixtures.py
++++ b/tests/unit/test_fixtures.py
+@@ -23,6 +23,7 @@ class TestPyTestFixture(unittest.TestCase):
+ def tearDown(self):
+ self.patched_betamax.stop()
+
++ @pytest.mark.skip(reason="broken with newer pytest version")
+ def test_adds_stop_as_a_finalizer(self):
+ # Mock a pytest request object
+ request = mock.MagicMock()
+@@ -33,6 +34,7 @@ class TestPyTestFixture(unittest.TestCase):
+ assert request.addfinalizer.called is True
+ request.addfinalizer.assert_called_once_with(self.mocked_betamax.stop)
+
++ @pytest.mark.skip(reason="broken with newer pytest version")
+ def test_auto_starts_the_recorder(self):
+ # Mock a pytest request object
+ request = mock.MagicMock()