summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild10
-rw-r--r--dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.32.0-r1.ebuild6
-rw-r--r--dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild8
3 files changed, 14 insertions, 10 deletions
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
index 540f323b3815..6083501408e4 100644
--- a/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
+++ b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI="5"
GCONF_DEBUG="no"
PYTHON_COMPAT=( python2_7 )
-inherit versionator eutils gnome2 python-any-r1
+inherit versionator eutils gnome2 python-r1
# This ebuild does nothing -- we just want to get the pkgconfig file installed
@@ -16,6 +16,7 @@ PVP="$(get_version_component_range 1-2)"
SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="LGPL-2.1"
SLOT="2"
RESTRICT="${RESTRICT} test"
@@ -23,10 +24,9 @@ RESTRICT="${RESTRICT} test"
# From the gnome-python eclass
RDEPEND=">=x11-libs/gtk+-2.6:2
>=dev-libs/glib-2.6:2
- $(python_gen_any_dep '
- >=dev-python/pygtk-2.14.0:2[${PYTHON_USEDEP}]
- >=dev-python/pygobject-2.17:2[${PYTHON_USEDEP}]
- ')
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.14.0:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.17:2[${PYTHON_USEDEP}]
!<dev-python/gnome-python-2.22.1"
DEPEND="${RDEPEND}
virtual/pkgconfig"
diff --git a/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.32.0-r1.ebuild b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.32.0-r1.ebuild
index 18367683dba2..8099b33f461b 100644
--- a/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.32.0-r1.ebuild
+++ b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.32.0-r1.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python2_7 )
GNOME_ORG_MODULE="gnome-python-desktop"
GNOME_TARBALL_SUFFIX="bz2"
-inherit gnome2 python-any-r1
+inherit gnome2 python-r1
# This ebuild does nothing -- we just want to get the pkgconfig file installed
@@ -17,11 +17,13 @@ HOMEPAGE="http://pygtk.org/"
KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="LGPL-2.1"
SLOT="0"
# From the gnome-python-desktop eclass
-RDEPEND="$(python_gen_any_dep '>=dev-python/pygtk-2.10.3:2[${PYTHON_USEDEP}]')
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/pygtk-2.10.3:2[${PYTHON_USEDEP}]
>=dev-libs/glib-2.6.0:2
>=x11-libs/gtk+-2.4.0:2
!<dev-python/gnome-python-extras-2.13
diff --git a/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
index cfcd4a3af74e..6744b4c211c5 100644
--- a/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
+++ b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
@@ -4,16 +4,17 @@
EAPI="5"
PYTHON_COMPAT=( python2_7 )
-inherit versionator autotools eutils gnome2 python-any-r1
+inherit autotools eapi7-ver eutils gnome2 python-r1
# This ebuild does nothing -- we just want to get the pkgconfig file installed
MY_PN="gnome-python-extras"
DESCRIPTION="Provides python the base files for the Gnome Python Desktop bindings"
HOMEPAGE="http://pygtk.org/"
-PVP="$(get_version_component_range 1-2)"
+PVP="$(ver_cut 1-2)"
SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="LGPL-2.1"
SLOT="0"
RESTRICT="test"
@@ -21,7 +22,8 @@ RESTRICT="test"
# From the gnome-python-extras eclass
RDEPEND=">=x11-libs/gtk+-2.4:2
>=dev-libs/glib-2.6:2
- $(python_gen_any_dep '>=dev-python/pygtk-2.10.3:2[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.10.3:2[${PYTHON_USEDEP}]
!<=dev-python/gnome-python-extras-2.19.1-r2"
DEPEND="${RDEPEND}
virtual/pkgconfig