summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.22.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 43647ebc9276..c4d38c2ed07f 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,4 @@
DIST google-auth-2.19.1.tar.gz 230290 BLAKE2B c7f76e1bd936d4d76c81e19fbf6bb50dfe700666d8eb234f762253547fd670d1d26a97a7fe4457bdb719712d32e28e3c8f9adc82c475ee6830f5fd2af994bb3a SHA512 8a8106abb1a0966254caa2e568fe9a9c887601b19e5309f4d43e1b07f3e3280ad358cf8999e34719d6f23473b263d128a2d0321f0ff184c4e188b0b5cf88a6ee
DIST google-auth-2.20.0.tar.gz 229669 BLAKE2B 547cb99cb72a4a5b224fdfff2bf156effe1cce5d7b4316b16530b1a3bbe50ab24dc54520fce3206fb2cea3fde1ca0c35f7bf5920e5128a5ed1bed13883fc75e5 SHA512 e13471f4452bd5c69c2ca9d1ff145431b160805e4ab2d3a70c35cad78c6e3e4f4bc789dfe99f55a0e60e5f335f9983529eabbfb0fc50794b62dfa7eeb70882b1
DIST google-auth-2.21.0.tar.gz 230720 BLAKE2B a572770d17ce2e8d68c92dad2fda68dc860d232845f5fb2d6beb51d583a8cf5d8820e7ef7921895c60da3d022c1b82b50054bff6c969071a87cc059e759a82ce SHA512 d84eec3da181e02ab293af76261f4cff50afc98d044e3a9e70b023a7b9e4e0ea7c46265de273f2363494d36ab6ec1894acb82e9125f30da6133692d2b86ef8eb
+DIST google-auth-2.22.0.tar.gz 231433 BLAKE2B 07b813209ce3f5ff429c4f9417141fa85029ff3eedb116664d6effdf508497ce6b6552fa4c3b6f9f1e7f1ffe9b9ae8ce72c8c727d277662bb9f8214ccd152b66 SHA512 c2c04e9ad367dd96bf00af7b19c7d897dd9fe3f8e9318b7436ec85a5c146b29c273cc718932956e97b2e4a1e2f12d0d10e835b6cf0f4e46ee19f6aaeed492b5e
diff --git a/dev-python/google-auth/google-auth-2.22.0.ebuild b/dev-python/google-auth/google-auth-2.22.0.ebuild
new file mode 100644
index 000000000000..fae7f6b53c35
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.22.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/googleapis/google-auth-library-python/pull/1290
+ "${FILESDIR}"/google-auth-2.20.0-urllib3-2.patch
+)
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}