summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-openid/python-openid-2.2.5-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/python-openid/python-openid-2.2.5-r1.ebuild b/dev-python/python-openid/python-openid-2.2.5-r1.ebuild
index 20929ce8d3ab..895572db7ae6 100644
--- a/dev-python/python-openid/python-openid-2.2.5-r1.ebuild
+++ b/dev-python/python-openid/python-openid-2.2.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,11 +20,12 @@ IUSE="examples mysql postgres sqlite test"
RDEPEND="mysql? ( >=dev-python/mysql-python-1.2.2[${PYTHON_USEDEP}] )
postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? ( dev-python/twill
- dev-python/pycurl )"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/openid-python-openid-b666238"
+# Tests depend on twill, a broken package. Bug #285169
+RESTRICT="test"
+
python_prepare_all() {
local PATCHES=(
# Patch to fix confusion with localhost/127.0.0.1