summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.5.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 50b91a363135..e170c2298fb5 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,3 +1,4 @@
DIST pytest-mock-3.3.1.tar.gz 27551 BLAKE2B 9e3602b988c0e27caa295d42d7400cbe7e3e30392511e662fa6ec16ec9fa4ef776d3e64b63b0345d1b520f753c6776103f507f91f0bad022544bfccc510b7e6b SHA512 ffd53974f82f725cf3bdbe750c1deb568ad1a12a67532eca93ff28d80b1cbcd8ebf709985f5473717c9d54345b251c1627c0567821e9e8b9e102db5c16cf7421
DIST pytest-mock-3.4.0.tar.gz 28115 BLAKE2B 0a7f9098955d57f7121c04f7ab706dd67eb52d8ec0b2254552460eb90b2e3fef3cd3b925cf46619532ffe7bede2f208bf822e465647f3ac4504566c18ff58a75 SHA512 5456b60bdd06a63859232b28aeb79be643e8298e69ae103cb6e194891987e01b17771ad895dfead97fa45531959689fb202bb1ebc9ba44491098760c10d1ef43
DIST pytest-mock-3.5.0.tar.gz 28903 BLAKE2B 39490d30546ad7419a16309a60cc7a3d8090cb38c11ca89d41034264147501fcd1ca52b26d391425df043b7234a0dc0b1255b973f93c8f40898a19d364df2e77 SHA512 ca85c49144a2dba83b4e3c5cfc5a82ddb631429271a4b87af686ba738f8137fe87db22121e4c04d04038c0bc786a555e882bfea21d667d1ed9f67c21b208d4ce
+DIST pytest-mock-3.5.1.tar.gz 29135 BLAKE2B f9eb37bff0965772919c359ad56a0cdd0cac24fa763685c42ffaa2dfaea183a9c0be480269cbfc80990baaf406021c541b6dccc09602e98c8f731bbd530e928a SHA512 28ab2f239d3dfee134dd4e4fd467109cf3c76cb60aeb537dbc0c21b9a7619d068d54737e33d98c585e9341588fdafba4737ea5f428af37796f55e61ec30373a7
diff --git a/dev-python/pytest-mock/pytest-mock-3.5.1.ebuild b/dev-python/pytest-mock/pytest-mock-3.5.1.ebuild
new file mode 100644
index 000000000000..8f3aa84f0a71
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-3.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if has_version dev-python/mock; then
+ # test fails when standalone mock is installed
+ sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i tests/test_pytest_mock.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest --assert=plain -vv || die "Tests fail with ${EPYTHON}"
+}