summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mkdocs-i18n/Manifest1
-rw-r--r--dev-python/mkdocs-i18n/metadata.xml17
-rw-r--r--dev-python/mkdocs-i18n/mkdocs-i18n-0.4.4.ebuild25
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/mkdocs-i18n/Manifest b/dev-python/mkdocs-i18n/Manifest
new file mode 100644
index 000000000000..386717aea65f
--- /dev/null
+++ b/dev-python/mkdocs-i18n/Manifest
@@ -0,0 +1 @@
+DIST mkdocs-i18n-0.4.4.tar.gz 17191 BLAKE2B 4ab926befac2c90b6b9ff55fd6887c8b78e88f801c820749df125ea97418fbfb0a8531b2168b508737e7dffbf426826433211ee80f25b80a42ae160f78a93670 SHA512 f9f27c0f274aa7ee5c64cee46d4165d51022cac0171f95a238b62c911e1be16b6a4ff227fea3b78de2ffa0095b9c95280e8919e207e6947db300a136fe16e659
diff --git a/dev-python/mkdocs-i18n/metadata.xml b/dev-python/mkdocs-i18n/metadata.xml
new file mode 100644
index 000000000000..da9fc6260b47
--- /dev/null
+++ b/dev-python/mkdocs-i18n/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">mkdocs-i18n/mkdocs-i18n</remote-id>
+ <remote-id type="pypi">mkdocs-i18n</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/mkdocs-i18n/mkdocs-i18n-0.4.4.ebuild b/dev-python/mkdocs-i18n/mkdocs-i18n-0.4.4.ebuild
new file mode 100644
index 000000000000..925326567abd
--- /dev/null
+++ b/dev-python/mkdocs-i18n/mkdocs-i18n-0.4.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="MkDocs i18n plugin"
+HOMEPAGE="
+ https://gitlab.com/mkdocs-i18n/mkdocs-i18n/-/tree/main
+ https://pypi.org/project/mkdocs-i18n/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/mkdocs-1.1[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+"