summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pathlib2/Manifest1
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pathlib2/Manifest b/dev-python/pathlib2/Manifest
index 11a4072ab0b6..eaa58436aa6f 100644
--- a/dev-python/pathlib2/Manifest
+++ b/dev-python/pathlib2/Manifest
@@ -1,2 +1,3 @@
DIST pathlib2-2.1.0.tar.gz 30390 BLAKE2B e009fa866dcdb2a6f078d746c423484bd90df049d59c89427c631cd63ac11376bb5549f45f0e98da036b15c6674040ffc8844fc08b95abb1d677783dedf9e126 SHA512 5dad54d4bf7a37a2c425afeca030a23d802a8a450186292f3d80aa9ee5c2985701871a0386a2f58e2b05b4bbfd7734a238d0a73625c5839237e4f3984088a8b1
DIST pathlib2-2.3.0.tar.gz 34291 BLAKE2B ef1768f8a9cc9b28f85ef84c0dfdbfce0b0087c1ffb6718e2b13eb007ea3e0ab0eebe946a1bcc2683fed7db46867f415ad2b52abedcdc87fb67bd45d5998aea5 SHA512 715fbd981d42767862dcaf2cc0fee31b9ec5050915ef7d909d14587609a7a5939e32b39736b586a890e7625443bb163832896fcf138b5c2863c451b71c36a124
+DIST pathlib2-2.3.2.tar.gz 33764 BLAKE2B c652069d60f489e482c6d75c0a201c5ac67c6b18b4acd6c8b00f7f12832f7165a45293d93ca7f6c45f1451c842e59931b6b8c45608de1bac91ad822cc3536105 SHA512 46ba0cc8b26006bc4cb914118b7c453dc49cc8a80147ea7a4b3d5a17e97d5538c5d73a3029bd7e5b59f42f256baba30ea273382e57468df1a459ac6f7c237ddc
diff --git a/dev-python/pathlib2/pathlib2-2.3.2.ebuild b/dev-python/pathlib2/pathlib2-2.3.2.ebuild
new file mode 100644
index 000000000000..3fe4dfe28789
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2 python3_4 )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_pathlib2.py -v || \
+ die "tests failed with ${EPYTHON}"
+}