summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/furo/Manifest1
-rw-r--r--dev-python/furo/furo-2024.4.27.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/furo/Manifest b/dev-python/furo/Manifest
index c07004ff0d6d..8873ea9d6786 100644
--- a/dev-python/furo/Manifest
+++ b/dev-python/furo/Manifest
@@ -1 +1,2 @@
DIST furo-2024.1.29-py3-none-any.whl 325212 BLAKE2B 7dec8d515bb2ac6741d875dac57048e066f6e9602e7c529bfcf5b01a8b47d6ff38d6212d5a5abf8dfbe42d7667481a3a14c20f39367d65d8968e429e6c5fbbea SHA512 375fff9ad283732c0e242da0233e6b3e5bc570c514fa1a5899232599ac1a73c3198071e74635ab115ba28ea9d97156e1c28ae40c5e203cc21cf639b183201893
+DIST furo-2024.4.27-py3-none-any.whl 330359 BLAKE2B 4c6997cb8335cbaf9926cfb8d650edb0baec735858bb141e3a63d24e2bc48bdbaff504539aa449e4f76ca1890e987bdbaaf3e0e55f441e3a5c6467ed6dc94a6c SHA512 2790121eccde99771fe219d7d32887e243eafe87cfe3736cb26d9ae83190bbbe25fe629195f080df8632d51e1644cb142f6433f768e245c9ca0a44b25297279b
diff --git a/dev-python/furo/furo-2024.4.27.ebuild b/dev-python/furo/furo-2024.4.27.ebuild
new file mode 100644
index 000000000000..d306ea1caab9
--- /dev/null
+++ b/dev-python/furo/furo-2024.4.27.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="$(pypi_wheel_url)"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+src_unpack() {
+ if [[ ${PKGBUMPING} == ${PVR} ]]; then
+ unzip "${DISTDIR}/${A}" || die
+ fi
+}
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}