summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/crispy-bootstrap4/Manifest1
-rw-r--r--dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild38
-rw-r--r--dev-python/crispy-bootstrap4/files/crispy-bootstrap4-2022.1-test.patch17
3 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/crispy-bootstrap4/Manifest b/dev-python/crispy-bootstrap4/Manifest
index c8ca1b4b70f4..93eb3e0186a0 100644
--- a/dev-python/crispy-bootstrap4/Manifest
+++ b/dev-python/crispy-bootstrap4/Manifest
@@ -1,2 +1 @@
-DIST crispy-bootstrap4-2022.1.gh.tar.gz 30814 BLAKE2B 573847b614b5f6cf71fea6ed6831eeef48ac01b2c2db07653d600b5b0829209188d235a143585ed4fabb663264aff3b5f7a416d99d12a8e268d4c62edaf3db84 SHA512 7f1e5443229274de2aaf28bd63507bbe5dff7923f27509801ea9de9246fa393bfc4563a4aa6d586a1e642b87bb7dddcb3ad3403653912c0197f8638141c42229
DIST crispy-bootstrap4-2023.1.gh.tar.gz 31707 BLAKE2B 0a3c4c1b86ba9701365f1fcfb90811e1f6793fb9f374a510410c460bc62a48e06b72a75330f0efd3a06e51380f457eea66f236488774c3ee6bf758510136f08b SHA512 fbbc8c6e0f4351b50b0fa3a4d2faefb0775906c995f42cf9ccd9688d4780e05877a9a53f065ad92785d135a560064809f429dbcebe9f257f65f063d9539973e8
diff --git a/dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild
deleted file mode 100644
index 98602ed39570..000000000000
--- a/dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Bootstrap4 template pack for django-crispy-forms"
-HOMEPAGE="
- https://github.com/django-crispy-forms/crispy-bootstrap4/
- https://pypi.org/project/crispy-bootstrap4/
-"
-SRC_URI="
- https://github.com/django-crispy-forms/crispy-bootstrap4/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/django-crispy-forms[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-django[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-test.patch
-)
diff --git a/dev-python/crispy-bootstrap4/files/crispy-bootstrap4-2022.1-test.patch b/dev-python/crispy-bootstrap4/files/crispy-bootstrap4-2022.1-test.patch
deleted file mode 100644
index 1432235e3b56..000000000000
--- a/dev-python/crispy-bootstrap4/files/crispy-bootstrap4-2022.1-test.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/tests/test_form_helper.py 2023-04-01 18:48:25.847263389 +0200
-+++ b/tests/test_form_helper.py 2023-04-01 18:48:38.817091994 +0200
-@@ -633,14 +633,6 @@
- assert '<div class="form-group row">' not in html
-
-
--def test_template_pack_bs4():
-- form = SampleForm()
-- form.helper = FormHelper()
-- form.helper.template_pack = "bootstrap3"
-- html = render_crispy_form(form)
-- assert "controls" in html # controls is bootstrap3 only
--
--
- def test_passthrough_context():
- """
- Test to ensure that context is passed through implicitly from outside of