summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sh/Manifest1
-rw-r--r--dev-python/sh/sh-1.14.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/sh/Manifest b/dev-python/sh/Manifest
index 1d4acecd50c1..d161642fcd2d 100644
--- a/dev-python/sh/Manifest
+++ b/dev-python/sh/Manifest
@@ -1 +1,2 @@
DIST sh-1.14.1.tar.gz 63317 BLAKE2B e4439a54d4bf2c106ae5217b55d6fa19f2bc369fb63e8515954a017fd2e98eca88fce07ea3efa70b3c427826bec657aa75c057a09c88de76c1595ef89465ee32 SHA512 9a4d9b841e81ae465b036f3fbf5e8ca277b090ffada660b17e9c2c457e09f7dbb0038b687fc0c0f4a6d575a55deb451c572a60f92f8c8d18ea65d6d902abb9b4
+DIST sh-1.14.2.tar.gz 63779 BLAKE2B adc9004334a53f3704e22c318df6b4f60fd9ca2d31f5a9601f84abfaf0fe2ded06938b165e10b1a977ed38fcad7d0fa08799f2f552fc2c6b9b4c2a6476477115 SHA512 b7917504ae85606e1986b681274077777ad3011639bfe933d4133c3ed16f930842e03b572caa396ca4d58f41fd5594bef776cc16c4b0fbd1242e57c6aad19e62
diff --git a/dev-python/sh/sh-1.14.2.ebuild b/dev-python/sh/sh-1.14.2.ebuild
new file mode 100644
index 000000000000..a8a1c5f8050d
--- /dev/null
+++ b/dev-python/sh/sh-1.14.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}/sh-1.12.14-skip-unreliable-test.patch"
+ "${FILESDIR}/sh-1.14.0-skip-unreliable-test.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}