summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild b/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild
index 5766d731686f..d38cfc41188e 100644
--- a/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild
+++ b/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild
@@ -13,12 +13,16 @@ SRC_URI="https://github.com/osrf/osrf_pycommon/archive/${PV}.tar.gz -> ${P}.tar.
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-RESTRICT=""
+IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="dev-python/mock[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
-BDEPEND=""
+BDEPEND="
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
PATCHES=( "${FILESDIR}/str.patch" )
distutils_enable_tests pytest